Roadmaster71

Members
  • Content Count

    201
  • Joined

  • Last visited

Everything posted by Roadmaster71

  1. I am at the point where I need to remove the Temperature / Ammeter gauge cluster so I can replace both of them. How do I remove the temperature sensor cable without breaking anything? It looks like I can pull back the protective fabric sleeve by expanding the split collar. What's next? The replacement unit I have seems to have the end of the cable crimped onto the back of the meter. I'd hate to pull on that and destroy the capillary tube and let out the gas it is filled with. Am I supposed to remove the sensor from the block first, then remove those two screws and thread it all through the exit hole in the meter? Photo below. Thanks!
  2. This thread and a couple others have been very helpful to me with the removal of the instrument panel in my 1941 Buick. I wrote a blog post that may be helpful to someone who has to do the same job. Just click on the link above to arrive there. A couple other related threads that may be useful: Removing the trip odometer knob Removing the fresh air vent Thanks to all the good folks who participate in this forum!
  3. Glad I can be of some help ... I get more than my share of help from the good people here.
  4. Thanks to the help received here the vent is out! I'll clean things up and replace the gasket tomorrow. While doing this I noticed that the hose to my wipers had fallen off. I guess that means I will be installing a new wiper vacuum hose. Maybe the wipers will work better?
  5. Tinindian ... that make sense about throttle clips. Possibly a source of replacement parts? I think my '41 uses through holes and cotter pins ... but I'm not sure. I do know that it was very easy to pull apart and replace when I swapped out my front carburetor. Thanks for the hint.
  6. Bob ... Thanks ... I will give it a try. I had poked it with a screw driver before but was afraid to break it. I'll put more effort into it now!
  7. Thanks to Neil I was able to remove the knob off of the trip odometer. First I re-tightened the hex nut to keep everything lined up. Then I braced the shaft with long nose pliers (the vise-grips were too cumbersome) and inserted a spring-loaded seam opening tool between the knob and the pliers. Several tries with lots of force popped it off. Then I was able to remove the shaft and put the knob back on (don't want to lose it) loosely with a couple turns of the screw. The seam opening device is the one I used many years ago to open up Macintosh computers that I needed to work on. It's a great tool to have. A photo (best I could do with only two hands) is attached. At this point the knob has popped off. And yes Neil, the shaft has a definite taper! You have the mind of an engineer. If you lived around here I'd invite you right over for a few beers (or iced tea .. your choice). Bonus: In the 16 years I have owned this car the trip odometer was stuck at 44,609 miles (or something like that). Now it suddenly works! I set it to 000000.00 miles. Maybe when I get the new speedometer cable in I will be able to track mileage and apply for the AACA M.A.P. (Mileage Award Program).
  8. Neil, Thanks for the input. I will give that a try. I have been documenting my progress with notes and photos. The first thing I did was to read the excellent thread on this board that is all about pulling the instrument panel. Boy was that a chore. Now I am working on removing all the gauges and wires and sensor cables. It's a lot of fun at 68 years old spending time on your back under a car dashboard. I don't usually do this stuff but I know the guys in our local AACA Region club (WPRAACA) have got my back. They encourage and lend a hand when I am really stuck. Eventually I will post to that other thread and make a posting to our own club blog. (I'm more comfortable with computers and writing than fixing old cars.)
  9. I am attempting to remove my instrument panel and replace several gauges , speedometer cable, and the panel itself. I got the 5 nuts off the panel and some of the other nuts are off too. But now I am having trouble with the trip odometer knob. I loosened the hex nut. I removed the small screw that is in the center of the knurled knob (replaced in attached photo). The knob still won't come off. Do I have to first release the cable from the speedometer and then feed it through the hole for the knob? I'm trying to do this without damaging anything. Suggestions welcome. Thanks!
  10. I started with a plan to replace my instrument panel with a nicer one. That led to removing the radio and ashtray & buying a new speedometer cable. An entire wire harness may follow. But before I get to all that I am now looking at the fresh air vent for which I have a new gasket but never installed it. I am having trouble figuring out how to remove the spring steel lock that prevents the linkage to the vent opening handle from slipping off. I did remove the four adjusting screws from the brackets but that does not loosen the vent enough for me to remove it and properly install a new gasket. I'm trying to get this off without breaking it. Any suggestions? Photo below.
  11. I spoke with Doug Seybold when I stopped at his booth (I think last year) at Hershey. He told me that it took him a long time to develop his technique. He claimed that the originals were a decal. I asked him about the green tint that I see on many originals. I thought that it was due to a lacquer overcoat. He said that the green is a result of degradation of the chemicals in the decal over a very long time; thus, it is not proper to tint a restored item green. For reference I have attached a photo of my 1941 Buick glove box door. This is a used replacement part I bought many years ago. I am pretty sure it is fully original.
  12. My car ran just fine as long as it was revving in the driveway. But while driving it began to miss when I put it in gear. It was most evident in third. I found that one of the spark plug cables was bad. The distributor end was not seating tightly .. the terminal appeared to be of the wrong type. I made a new cable with the proper terminals and the problem is now gone. So, are all the cables good? How about the distributor cap? So many choices. I'm sure you will figure it out.
  13. I tried the ammonia for one night. It helped a little. The best thing was leaving it outside with all windows open. I am now leaving the windows open while it is in the garage. Because of that I have re-baited about 10 mouse traps (even though the mice tend to stay away in the warm months.) The first day I left the car outside in the sun with all the doors open happened to also be the day that the maple trees decided to lose all of their winged seed pods. They flew right into the car along with all the caterpillars that are now hanging from the oak trees on silk threads. Oh well.
  14. Earl, I agree ... I do need that master parts book. I will probably order one from Fusick when I get done with paying for this front end job. I expect to get the car today ... they are finishing as I type this. It will be a big bill. They had to do a lot of work to make everything fit due to excessive wear on the old parts that everything attaches to. My car came out of Connecticut ... I bought it 16 years ago. It looks like you found a beauty! Perfect original interior? I would do the plastic covers too. That only comes around once and I suspect you want to use the car a lot. The covers will protect it. I notice you have the bumper end protectors and fog lights too. Nice extras!
  15. I'm going to try the ammonia just as soon as I get my car back from the shop. I warned the guys about the smell but they were not concerned. They just started with their own stories about smelly vehicles.
  16. I covered everything with baking soda and sprayed it with hydrogen peroxide. No significant change. I also vacuumed out all the debris they had stored inside the springs. CAUTION: Shortly after my first vacuuming of the seat springs i noticed that there was a tick on me. I could not remember going in the woods and so had no idea where it came from. The second time I removed nesting material from the seats I saw a tick on my pants while I was still using the vacuum. Those ticks must have been left behind by the mice. Be careful! Lyme disease is prevalent around here.
  17. You and several other people have the same suggestion. I will be visiting a pet store soon. Thanks so much!
  18. No smell or stains from the headliner. My wife patched that last summer so it wouldn't look so bad for my son's wedding. See my blog site for the rest of the story and photos.
  19. Funny you should mention that. I came close to buying a 1952 Cadillac Fleetwood Anniversary 4-door sedan. Gave up when I finally got guy to admit I could not test drive it ... no brakes and he wasn't interested in fixing them. So as of next Tuesday I will be having a nearly complete front end replacement so I can finally drive straight. I'm committed!
  20. I suspect this thread is long dead ... but hopefully someone else adds to it. My suggestions, only partially effective, are below. My car (1941 Buick Roadmaster Touring Sedan) has this same problem. I was able to get / reduce most of the smell. Then I goofed up this winter and failed to properly protect against mice. Late in winter I finally figured out where they were coming in by placing traps at the two ends of the garage door and at all four wheels. They were entering by the edge of the garage door where a couple inches of weatherstripping was missing. I put all my traps there and have since caught 3 mice. If I close that opening they will just find another. I'm better off leaving it as is. I put moth balls in the car, especially under the seats. It did not help. I put Walmart dryer cloths in the seats and floor. It did not help. My only solution has to been to remove the seats and clean out all the cotton fill that is inside the springs. (Does this stuff belong there or did the mice deposit it?) I wear gloves and yank the stuff out and also use a vacuum cleaner. The fill is sprinkled with mouse feces. I have even removed complete desiccated mice from the spring cavities. I don't know if that fill is supposed to be there but removing that and leaving the seats in the sun does help. I also scrubbed under the seats with powdered cleaner (Ajax?). Next stop will be new seats and more mouse traps. Some photos attached.
  21. The order from Cars came in. The parts look good and I reviewed them with the man who will do the install. The only concern he had is that the brackets that attach the lower control arm rod are an integral part of the entire casting. The originals appear to have a stamped bracket that is then welded to the cast rod. He will install this first. The holes do seem to match up (I measured). The other parts look good. The salesman told me that a nut was not included with the lower outer pivot pin kit. It does not have a separate nut but does have a threaded sleeve with an integral nut on one end. Hopefully this will fit. Almost the entire order arrived in about 8 days. The front springs that I ordered were drop shipped and they came a few days later. Some photos are attached.
  22. Jim, I do not have the part for sale but I can give you photos and dimensions of mine so someone else may identify a spare part they want to sell to you. The small bar: 5-3/4" long, wrench end for 3/4" nut, hole in other end 7/16" diameter I also have a plain long bar: 18" long by 5/8" diameter I measured as well as I could. I may be off a bit. These parts did not come with my 1941 Buick. I bought them separately from a vendor who claimed they were for the 1941.
  23. The tie rod ends are left hand threaded. Another area in the Cars catalog does specify this for all 1941 Buicks. Apparently the salesman was not aware of it. Also a friend of mine knows that the adjusting sleeves are left hand threaded as per the shop manual. I will figure out the nut size when I remove the one that I do have on the other side of the car.
  24. I am in the process of sourcing the parts needed to rebuild the front end of my 1941 Buick Roadmaster 4-door sedan. I have a couple of questions that have come up while consulting catalogs. I need upper and lower outer knuckle support pin kits (pivot pins). The kit offered by CARS (my preferred vendor at the moment) does not include the large nut that secures the lower pin (according to salesman). Mine is missing. Does anyone know the dimensions of that nut? I plan to remove and measure the one I do have on the other side of the car but would like your input. I measure the bolt as about 7/8" diameter and 10 threads/inch (coarse?) The kit comes with Tie Rod Ends. These have to be specified as right hand or left hand thread. What were they for 1941? I may have some terms wrong ... I am not very familiar with suspension parts .. please feel free to correct me. Thanks!
  25. That's a great story, Morgan! It's always nice when you get cooperation from nice folks. I sold my 1947 Mercury Station Wagon many years ago ... needed money to replace my wife's car that was stolen. A year or so after selling the car I got a call from the man who bought it from the man I sold it to. It seems that all of the brand new wood that I included with the car was no longer with it. At least I was able to point the guy to my source of new parts. My current car (1941 Buick) has almost no history. The guy who I bought if from (lives in CT) said at the time I bought it that "It came from out west", whatever that meant. I was so anxious to get the car home (a 90 mile ride) that I did not press him any further. A few years later I tried on two occasions to get more information but he claimed to know nothing. So it goes.