Recommended Posts

Hello, this is my 65. I have owned it for 22+ years but it sat parked for 13 years. I am one year into my resto-mod and I apologize for not posting a build thread sooner. Forgive me but I originally got the vibe that some of you guys (purists) may not like what I was doing (not staying 100% original) to such a beautiful car. Thanks to a few members who advised me otherwise and with the inspiration of the builds I have followed this year (Rsmalling, Rob J & Alini to name a few thank you for posting) here it goes

I really like this forum...I've been lurking and found lots of help already...I see some guys post their step by step build on multiple forums at once (that seems like a ton of work but prob multiplies the info gathering). I will update with pics and write ups... I hope you guys enjoy and thank you in advance

before the start...this is how it sat for 13 years without the engine in it. Note the nose high stance. I am trying to catch the interest of my 11 y/o son but video games are all kids care about today. Cool Hide-a-key find in the inner-fender/fender. My original plan was to rebuild the engine myself...got cold feet and sent it out instead. So I thought I would use the machine shop build time to clean up the engine compartment (fire wall, cross member, inner fenders, core support and tops of suspension components and frame for paint...) "can of worms" effect set in quickly. More to come...

post-89871-143142318206_thumb.jpg

post-89871-143142318234_thumb.jpg

post-89871-143142318258_thumb.jpg

post-89871-143142318283_thumb.jpg

post-89871-143142318307_thumb.jpg

post-89871-143142318333_thumb.jpg

post-89871-14314231861_thumb.jpg

post-89871-143142318636_thumb.jpg

Edited by MrEarl
change title per request (see edit history)

Share this post


Link to post
Share on other sites

these pics are from back in January. everything got power washed, scuffed up with sandpaper and taped...all in prep for paint. lots of things started to come off...(remember can of worms?) i was gonna go the rattle can route which I tested on that core support section you see. guys here suggested Rustoleum 7777...i liked the sheen.

pic of my son getting ready to pull the bumper...yea more things coming off

post-89871-143142319018_thumb.jpg

post-89871-143142318993_thumb.jpg

Share this post


Link to post
Share on other sites

you totally crack me up Bernie...thx for your humor

I am having a really hard time uploading pics from my computer to continue this thread. I seem to have better luck doing this from my phone app. Do you guys have any suggestions since all the pics are on my computer now. I would have to email pics to myself that I want to post, retrieve them, save them to my phone, then attach them to the post thru the app. Doable but I thought the computer route would be easier...not so far

Edited by RockinRiviDad (see edit history)

Share this post


Link to post
Share on other sites

Across the top of the reply box, fourth from the right end, is Insert Image. Go to brouse. Pick your computer, pick your hard drive and the pics you want to load. I generally look through my picture folder, as it is huge, and copy the ones I want to paste in my reply to my desktop so I can find them easy. You may already be doing this and it doesn't work, but it does for me.

Share this post


Link to post
Share on other sites

Thanks Steve. I have been using that tab but as soon as I select most pics it shows an "x" next to them. I learned quickly by trying multiple times that those pix with an "x" won't load from my external hard drive. I will try it like U said by transferring them to the desktop first. Thx

Here are pix (posted using my phone) of the motor during assembly at the machine shop. I can't find the before pix prior to sending it off. If I can find them later in the ocean of my wife's pix I will edit this post & add them.

Maybe someday when I grow up I will be able to build a motor just like these guys lol

ebyzesu5.jpgsubydu8y.jpgygasubyq.jpgapu2eset.jpgy3abu8up.jpgbumy8u5y.jpg9apeby5a.jpge9egehuq.jpg

Regards,

David

Share this post


Link to post
Share on other sites

David,

What operating system are you using on your computer. If it's Windows, I can guide you through a really easy way to post pictures.

Ed

Share this post


Link to post
Share on other sites

Another thing you might try is reducing the size first, if the file size is too large it will not upload either, maybe? What I usually do is make a copy of what I am going to post, use some kind of photoshop software and reduce its size, and upload that copy. It makes for "lots" of pictures on your computer but I never delete any of my original pictures. You might give that a try?

HTH

Share this post


Link to post
Share on other sites
David,

If it's Windows, I can guide you through a really easy way to post pictures.

Ed

Ed, no I am using a Mac. But thank u anyway.

Randell, this app I'm using has given me a sizing option before. Now it seems to have done the sizing thing automatically. On my last post the pix are def smaller when I view them on my phone.

How do they look on your end guys?

Regards,

David

Share this post


Link to post
Share on other sites

David, use a photo hosting service, and link the photos here. Easiest way to do it. I use photo bucket. BTW, I'm a Mac user as well. Would never go back to PC. I'm forced to use Windows 8 for work stuff, and it blows!!!

Share this post


Link to post
Share on other sites

Thanks Rob J. Not sure what that is but I will look into photo bucket. I looked at some of your pix & they look sharp. Mac's are very cool but I don't spend a whole lot of time on it. This is a perfect excuse to do just that.

Regards,

David

Share this post


Link to post
Share on other sites

David, it looks like you started out with a real nice car. Where'd you find it?

Hope you get the photo situation fixed soon, although the one's you're posting look pretty good. We Love Photos! :cool:

Share this post


Link to post
Share on other sites

Thx slosteve, I found the car here in So Cal, in a small town just outside of the San Fernando Vally.

Back when I was a kid I worked at a small "mom & pop" minor mechanic lube shop, great place to start for a kid. The shop was on a busy intersection where my boss had his buds park their cars with for sale signs on them occasionally. Lots of cool cars exchanged hands at that shop. One morning when I showed up for work that's where I found my 65. I'd never seen anything like it, didn't know the year, make or model of the car……really didn't care…as a young kid looks were everything (kind of still true today right..kind of lol) and she was beautiful. All I could think about was "how am I gonna make her mine" & "can I take the for sale sign off of her while I figure it out". My boss saw the gleam in my youthful eyes & let me squirm for most of the morning. 1200 bucks is what his friend wanted for the Riv…I didn't have that kind of cash…so my boss made me an offer…loan me $1200 if I agreed to paid him back $1500…no brainer even for a snotty nosed kid

Still a decent car but it def looks better in the pix than in person. Lots of wavy panels gets me to thinking maybe bondo? But I tried the magnet trick & it's still unclear.

I may try what Rob J suggested with the pix but I think photobucket charges for their service. Here's a couple more pix from my phone of another cool find…the protecto-plate & book. Shows its been a Cali car her whole life.

Also, I forgot to mention a sad detail when I posted the motor pix. It turns out the engine numbers on the leading edge do not match the vin number. That's what u guys mean about "matching numbers cars" right? I've had her so long that I just assumed it was all original…bummer right?

avuhyveb.jpg

u5y8u2et.jpg

Regards,

David

Edited by RockinRiviDad (see edit history)

Share this post


Link to post
Share on other sites

Ok, so the pix from the desktop method worked smoothly. I will look into the photobucket route tomorrow.

yes more parts coming off...Bernie is right about so many things coming off easy...I thought I had a concrete enough plan from the start I was only going to clean up the engine compartment...riiiiight. Years of power steering leaks, master cylinder leaks and oil leaks left the driver side saturated. As you can see from comparing the frame rails in the second pic. The third pic is the result of unknown man hours spent on degreasing, scrubbing, pressure washing (with a cheap unit) and wire wheeling with an angle grinder. The transmission is still in place cuz it thinks it's gonna be married up to the engine soon....not

post-89871-143142320113_thumb.jpg

post-89871-143142320059_thumb.jpg

post-89871-143142320088_thumb.jpg

Share this post


Link to post
Share on other sites
The transmission is still in place cuz it thinks it's gonna be married up to the engine soon....not

You're way past the point of no return. Don't stop now. Why not go all the way? It will only take another coupe of years and unknown quantities of cash. No hill for a climber!

Share this post


Link to post
Share on other sites
David, use a photo hosting service, and link the photos here. Easiest way to do it. I use photo bucket.

I set up a photo bucket account & test loaded a few pix but can't figure out how to link them to the forum.…yes I know…I'm an idiot lol. Can I PM u for direction with that?? Here are pix from my phone

Ed, ask and you shall receive…

The driver side upper control arm and frame rail came clean with hours of elbow grease. But I could only get so far under the arm & I could see built up crud on the underside.…so heck with it…suspension came off too…pretty nasty under there huh? I think u guys would agree u wouldn't have left the crud underneath & just painted the tops of everything. Or an I just naive???

Last pic is of frame ready for paint.

te2esetu.jpg

y4aju7u7.jpg

ubuneby6.jpg

udyvujer.jpg

Regards,

David

Share this post


Link to post
Share on other sites

How is this?

013.png

The parts are hanging on an old closet shoe rack that I found at a yard sale. I attached the top tp a cross tie in the garage ceiling so it swings up out of the way and is held by a hook. All the shoe holding wires make nice hangers for parts. I can walk around and give a nice coat to any odd items.

Your picture looks familiar:

006.png

Bernie

Edited by 60FlatTop (see edit history)

Share this post


Link to post
Share on other sites

RivNut (Ed), you asked for it…you got it…

Countless man hours on cleaning this frame with my 4-1/2" angle grinder. 4 cupped wire wheels later…

Crazy what a little determination (& lots of beer) will get you...

 

Rob J, these pics are from the photo bucket link. Works well but the reviews of the mobile app say otherwise. Do u have the app too?

 

Bernie, that rack is a genius move. Nice Stingray on the background too. Your frame turned out awesome. What paint process did u choose?

 

Regards,

David

Edit: photosuckit pix have been replaced 

 

E8095BFA-3F4A-4941-9406-3145014ACC2F.jpeg

7D37D8FC-9274-4B48-8DA8-57CC6768C42E.jpeg

Edited by RockinRiviDad (see edit history)

Share this post


Link to post
Share on other sites

This is my KBS-coatings.com product writeup.

 

Not sure how I decided to go with this product but so far it has me amazed. Apparently, these people are one half of the POR15 originators that had a fallout and KBS was born. I read that the KBS people set out to outdo their competition with this new & improved product. I can't tell you the difference cuz this is the only experience I have.

 

If u buy the kit I used it comes as a 3 step system. First step is their brand degreaser (AquaKlean), second is their zinc phosphate metal etch (RustBlast), third is one quart of their paint (RustSeal)

 

In my previous post the wire wheeled bare frame pic is after the first KBS degreaser step.

 

This first pic is the second KBS step (RustBlast). U can see (sorry don't know why the pic is sooo small, still trying to figure this out) the orange hue from what they describe as the rust flash & the chalky white film is from the zinc which they say helps with adhesion. Directions state not to wash it off.

 

6 hours later on a warm Saturday morning with a 2" paint brush on just the frame alone & wha-lah. Days later I did the same to the upper & lower control arms & spindles. Weeks later I did my rear axle housing, rear backing plates & trailing arms all with the $60 one quart of paint kit & I still have some left over (not much). This is a budget build & that alone proves it. I cant afford powder coating its expensive but people who see the end result of this product think it looks & feels like powdercoat. Cant comment on the durability yet still a work in progress.

 

The paint process went easy, it lays out nicely with very very few runs. Although instructions state to lay two thin coats I went with one heavy coat which did sag in a few spots. Note: the rear axle, rear backing plates & all control arms were the only things I had sandblasted.

 

Cons: the paint & zinc stuff smell bad while applying it. I didn't think it was bad enough for a mask but the wife kept yelling at me to put it on haha…I wanted the satin finish so that's what I ordered…as u can see their satin is not what we call satin right? Their gloss must be blinding :) …lastly like all types of these products…don't get any on your skin or anything valuable…it won't wash off...it grows off

hope you guys like...

 

7519F730-2D9F-4FFA-AF24-42CA089B9412.jpeg

 

1DDC7613-CF51-4FD9-94B9-3E8FA73A8A42.jpeg

 

DE329712-095B-4A87-99D8-60C1559ACE24.jpeg

 

Edited by RockinRiviDad (see edit history)

Share this post


Link to post
Share on other sites

Thanks, My frame was lightly sandblasted and epoxy primed. Then finish coated with Valspar satin black urethane. All the chassis blackened parts have the Valspar. It was done in the early '90's and looks fine today.

011.png

Bernie

Share this post


Link to post
Share on other sites

awww satin...the look I thought I was gonna get...looks good Bernie. You've got quite the library back there too. If that collection of books was from the 90's too then I'm sure they are much bigger stacks now lol

Share this post


Link to post
Share on other sites

Great job David. You've put a vast amount of labor into your project so far and it's obviously a labor of love. Looks like Ed pushed you way over the top. ;)

Steve

Share this post


Link to post
Share on other sites

Thank u slosteve. I have learned one huge detail about myself on this journey…I must have OCD & ADHD both in HD :)

But putting the blame on Ed sounds better…DAMN YOU ED!!!!

Regards,

David

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now