Jump to content

1914 Chandler water pump


Recommended Posts

I am rebuilding my water pump while I have the radiator out being rebuilt. I have taken the water pump all apart. I found some interesting markings on the bracket that the pump mounts to. The letters C M C CO and the number 600 are clearly stamped on it. I suspect the letters stand for Chandler Motor Car Company. I wonder if this was a part made by an outside vendor and supplied to Chandler. The "600" part number does not appear in the parts manual. The parts manual only listed the water pump as a complete assembly.

 

All of the original paint is long since gone on it. I previously painted it black which is how it was when we got the car. Looking at period literature the engine is pained Pearl Gray and the pump looks to be the same color.

IMG_3113.jpeg

IMG_3123.jpeg

IMG_3124.jpeg

IMG_3125.jpeg

  • Like 2
Link to comment
Share on other sites

This reminds me a lot of the pump on my 1913 Studebaker, as it sandwiches the impeller like that. The gasket directly affects the impeller clearance. In my case, the challenge was getting gasket material thick enough that the impeller would not bind. There wasn't anything available thick enough from automotive sources. Fortunately @37_Roadmaster_C came through with one last chunk of some unbelievably thick gasket material that had formerly been used on big refrigeration compressors in warehouses. I'll bet on some other cars you could easily wind up with the opposite, too much impeller clearance, and a pump that doesn't do much.

Link to comment
Share on other sites

21 minutes ago, erichill said:

Curious to what size rope seal you will be using. I have to repack mine as it is leaking. I have my 1919 radiator being re-cored and repaired  costing me $1900  Ouch!

Eric where is your radiator being repaired? Ours is still at Brassworks where a completely new core is being installed. Hope to have it back later this month. And I wish it only going to cost $1900 🫤

Link to comment
Share on other sites

13 minutes ago, Bloo said:

This reminds me a lot of the pump on my 1913 Studebaker, as it sandwiches the impeller like that. The gasket directly affects the impeller clearance. In my case, the challenge was getting gasket material thick enough that the impeller would not bind. There wasn't anything available thick enough from automotive sources. Fortunately @37_Roadmaster_C came through with one last chunk of some unbelievably thick gasket material that had formerly been used on big refrigeration compressors in warehouses. I'll bet on some other cars you could easily wind up with the opposite, too much impeller clearance, and a pump that doesn't do much.

Hi Bloo,

The impeller was remade on mine by a friend about a year ago. I'll be playing with the gasket thickness when I get this put back together. I had used a rubber gasket this last time, but it continued to leak a bit. 

  • Like 1
Link to comment
Share on other sites

1 hour ago, 29 Chandler said:

Eric where is your radiator being repaired? Ours is still at Brassworks where a completely new core is being installed. Hope to have it back later this month. And I wish it only going to cost $1900 🫤

Marietta Radiator Service here near Atlanta. It will look slightly different from the original but for me that's fine as it was 1/3 the cost.  I have a Braasworks radiator in my speedster and have never had issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...