Jump to content

Rod L

Members
  • Posts

    127
  • Joined

  • Last visited

Everything posted by Rod L

  1. Forgot my contact information. rod@customfurniture.net PS I will be putting up a website with newer photos (those in this ad are over a year old, but the car has virtually gotten better (swirl removal and paint correction performed)). I will also provide a starting/running/driving video. Use the email address to contact me, and if desired I will then provide a phone number. The car is in Eugene Oregon. Rod
  2. Selling my Buick. Need to down size the collection as age is entering into the collecting equation. $42,000.00 OBO 1928 Buick 24 Sport Roadster Excellent condition. National first place 1981 AACA winner. New paint (stunning match to fabric top) New top, side curtains and top boot. Rumble seat with newer leather covered seat. New matching green leather interior upholstery New clutch assy. New coil Folding windshield. Marvel Carburetor replaced with new down draft (original marvel carb to accompany car). New Optima “red top”6 volt battery (march 2021) Recent tune up and service including replacement of transmission fluid Great oil pressure. Runs great. Some documentation leading all the way back to the 1st purchaser as well as the restoration which lead to the awards.
  3. Just saw this recent post, Jon, thanks for the comment. TriumphDude, good luck with your conversion. I can tell you that I have been very happy with converting, except for the initial carburetor issues I have been quite happy with the conversion, the car runs spectacular wth the generic carb on it, no issues what so ever, Starts instantly, idle is as it should and accelerates smoothly. I couldn't be happier. If and when I should sell the car, all the stock parts will go with the car. Rod
  4. Wow!! Thanks for all the great replies and excellent ideas, Im sure to get her points pointed in the right direction. (pun intended-- sort of).
  5. Want to ck/set the point gap, but don't have a hand crank (1928 Buick sport roadster). Any suggestions on what might work as a hand crank or where to get one? Rod
  6. 41, Perhaps I am misunderstanding your statement, but I am not running a Pertronix module, just their coil. Rod
  7. Thanks Terry, I'm just playing around trying to see what works and what doesn't. The wires and rotor appear to be fairly new. That pertronics site is a little confusing with their charts etc, which is why I asked the question. I'm going to play with this a bit, changing plug gap trying to find a sweet spot. I bought an "innovate LM-2" exhaust gas analyzer recently in an effort to dial this thing in, but with only an end of tailpipe sniffer it isn't steady enough to do much good, might have to weld in a bung further up the pipe for the O2 sensor? Rod
  8. I'm a little bored so I checked the plugs and found all 6 to be set at .020 I reset them to .025 resulting in some improvement. Then I got to thinking about the coil. I have a "Pertronics" # 40011 1.5 ohm brand new in the box. can I use it , or am I better off using a 3.0 ohm? Rod
  9. Castricum, sorry but it has sold. I do have two other Model A's, both in excellent condition. Another deluxe coupe (1930) with rebuilt engine, transmission and rearend. $27,000.00 And a 1930 Phaeton that is like it just rolled off the assembly line $28,000.00 Both have just been color sanded and buffed to a perfect shine. See below
  10. Well I received the new carburetor and installed it today https://newcarburetors.com/?product=y200-universal-carburetor This is a new, not rebuilt unit. Straight out of the box, the car started right up, I adjusted the idle mixture using a vacuum gauge to 60" max it has about a 2" intermittent drop. 58-60-58-60.... The prior issues: intermittent miss, stumble and near closed choke requirement are all gone, so I think I was was right about the Carter w1 being defective was correct after all. Lots more power than originally but some of that increase is probably the result of my adding in a couple degrees of timing. I'm going to go back and reset the timing to stock just to see where that gets me. I'll bet that even with the~2 degrees I added, it will still be retarded. I don't know at this time if I'm going to keep the down draft or take her back to the Marvel????? unfortunately the rains are about to start out here in Oregon, and I will be storing her for the duration. Thanks to Ed, Hugh, Ben, Tony etc etc for your input on this thread. At some point I'll put up a step/by/step of how i did this conversion, maybe if it dries out long enough I'll get some miles on it and some more info. Rod
  11. Ed, I am pretty certain there IS a vacuum leak in this carb. I have totally isolated it from any other source of a vacuum leak. the only connections to it are the fuel line and the throttle linkage. Using your "propane" test I get no reaction at the gasket between the carb and manifold or any where externally, but when the engine starts bogging down and I apply the propane to the inlet, it immediately levels out and runs great. The same reaction as choking it. We are not talking high rpm's or no more load than coming off idle up maybe 50-75 rpm while parked. it seams to me that adding this carb would in all likelyhood create a rich condition not a lean one? just saying. Rod
  12. Yes, the lean condition is what I've been talking about for some time now and that is why this carb is going back and another one is on the way. When I ordered the intake manifold gasket, I also got the exhaust manifold gasket, I think the ports are the same, so those exhaust gaskets should work in the intake ports, if so, I might put the marvel back on and see what it is like with the timing advanced. (just for shi.. & giggles). My conversion to the down draft is not set in stone, but i'm a stubborn old fool pretty intent on seeing something through once I start it.
  13. Thanks Larry, Geeez, could they have not have found a more perfect spot! So far here is what I am finding on the engine. 1. Checked the battery and coil voltage: Battery = 6.09 Coil = 5.91 so some voltage loss there, don't know if that is significant? 2. Advanced timing ~ 3* (a guess) Engine likes that with power increasing but still requires choke only open about 3/8". 3. used propane in the intake of the carb as per Ed's instruction and the stumbling was somewhat reduced, so there is a vacuum leak somewhere. I had already disconnected all the vacuum connections and plugged the nipples etc; so I'm certain the leak is within the carburetor itself. Directing propane at the base of the carb (gasket) does not influence the engine at all. Of note on the test drive, is that with the increased timing and adjustment of the choke to get a richer a/f mixture results in what I would describe as what the engine would have been from new. Also there is no detonation (pinging) that i can hear, though it would take a "knock sensor" to truly know. I have done considerable work with a laptop tuning an engine equiped with sensors for timing, A/F mix (stoichiometric) and knock sensors, so I'm not completely in the dark. One thing I'm seeing is that movement of the timing lever does not make a significant difference in engine rpm, nothing like my Model a's so maybe a linkage issue as well? I am sending this carb back and getting a new one with main jet adjustment. Zenith 28/228
  14. Thanks guys for the new comments-suggestions, all are appreciated. I have been tied up with a wet sand/buff project on one of the "A's" and hope to get back to the Buick today - After Voting of course! Rod PS Where exactly is the inspection cover to view the timing mark on the flywheel? I'm looking on the distributor side and see nothing.
  15. Thank you Ed, Grimy, And everyone else who have offered constructive advise on finding out why this engine is misbehaving. I have made a list of all the suggested items to check. This is going to take some time and I will keep posting findings as I get to them. First off though is the down draft carb. I need to figure out if it is also misbehaving as it only has a 60 day warranty. This morning I replaced the intake manifold gasket as well as the carb to manifold gasket. I checked (starter fluid spray) at all the suspected areas for a vacuum leak. I didn't detect any. I took the car for a drive and there was some improvement but still some coughing (slight) and a little backfire. Then this interesting thing: while driving, if I advanced the hand throttle the engine hesitation (missing?) evened out. Also note that the hand throttle was no longer connected to the foot throttle. i.e. when moving the hand throttle the foot throttle stayed stationary. what is the hand throttle connected to at the end of the steerng column? (SEE PHOTO) Rod
  16. After reading all the posts in this thread I think i need to reiterate what exactly has been the issues with this engine and i'm going to do it numerically in the order in which they occurred: 1. Bought the car in March of this year. 2. Noticed on the 1st drive that there was a noticeable lack of power in all gears at all rpms. There was NO missing or back firing at this time!! It did run really rich. 3. Read of the possibility of reversing the manifold and using a down draft carburetor because multiple people were reporting issues with the Marvel. (at this time i knew nothing about this type of carb). 4. drove it through the summer. 5. Asked on this forum for a recommended carb rebuilder. NOBODY recommended. 6. Based on that recommendation I decided to proceed with the downdraft. 7. Using the recommended carb (Carter W1) I completed the install Now here is the pertinent information Remember item 2 in parentheses "There was NO missing or back firing at this time!!" Now with the new carb installed I am getting missing and occasional back firing. In my backward and ignorant way of reasoning I would and am assuming that if there was no missing etc before the carb was changed and there is after, then the missing and back firing has something to do with the new carb. It didn't happen before only after. I'll bet if I put the marvel back on, the missing and backfiring goes away? Rod
  17. Well, unfortunately myself and a good number of the rest of us don't think so highly of ourselves and just keep stumbling along hoping that a question we might ask might be reasonably answered without being dissed as ignorant fools. I'm sorry I started this thread. Rod
  18. I really don't want to push this Marvel switch controversy too far, but here is something to contemplate for the future (maybe sooner than expected). If no one steps up or is qualified down the road to work on and adequately repair the Marvel carburetors, then what will be the answer. It would seem to me that without a means of repair everyone including the "purest" will be forced to go with something other than the Marvel or maybe it is their intention to create a knock-off "Marvel"? Can you imagine the cost of that item, I should think pretty cheap considering the huge demand.
  19. Grimy, Finally someone with some actual help, thank you so much, it is much appreciated. No the stumbling, miss and backfire that is occurring with the Carter down draft, did not occur with the Marvel. The Marvel equipped engine just had very low power and as I mentioned in another post, the model A's I have are much more peppy. I hope to get it out this weekend to see if my changing the intake manifold gaskets made a difference. Again thanks for the help and for staying on topic.
  20. And still no Marvel carburetor re-builder recommendation.
  21. I guess I just don't understand a statement like that. When you have no idea as to how the car was running at the time that I decided to go down draft. If there was a carburetor shop capable of rebuilding my existing Marvel then why wasn't it recommended? Being it wasn't, that left me with two choices: park the car or go down draft. Now that I have gone down draft, I am accused of not listening to the offered advice and if you look closely you will note that STILL no where has anyone pointed to a capable Marvel carb re-builder. I have completed what appears to have been a successful conversion (so far). The engine (with the Carter w1) starts, idles and accelerates just fine (with no load). It does not like accelerating under load, and that is the issue. I am certain it is something to ,do with the carburetor, i just don't know what! I guess maybe I need to go to a Carter forum to find my answer. Sorry to have troubled the "experts". Rod
  22. Ed, Wow, aren't we spicy this morning! If you were to have read all the posts in this thread you would be aware that in my 2nd post I asked for a recommendation for a re builder of the marvel should I decide to go that route, you would then be aware that NO such recommendations arrived! I then proceeded down the down draft trail. I also did follow Carbking's advice and used the Carter w1 carburetor (the one I am seeking assistance with. Also being 78 years old and while not an expert on these cars, I have modest mechanical abilities and have been at this awhile.. As for all this help I'm being offered, could you point me too it? Only "Oldtech" has answered my question.
  23. As to the last two responses, Edinmass & dibarlo, I didn't ask for a critique! Neither of you gentlemen have driven the vehicle in question and have no idea as to the nature of its power, I am not trying to hot rod or even make a "1958" out of it. I have retained the complete Marvel system for the next owner should they chose to use it. The poster prior to my last post, suggested a possible adjustment to the carb I am using, I was merely seeking clarification for his suggestion and NOT someone else's opinion as to the merits of what I decided to do. If you don't have a directly related answer to the question asked, you are just making noise. Rod
×
×
  • Create New...