64Nail

Members
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

3 Neutral

About 64Nail

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. It’s alive! i rethreaded the port on the housing and put on a flare nut that works with the stove pipe bolt. Thanks for the input guys!
  2. Tab says 3665. Stamp says A9B 3665S its a 64 riv without AC how does the stove pipe hose attach to the exhaust manifold? ill hafto disconnect it so I can remove the nut and reflair the end
  3. So I was installing my freshly rebuilt carb on my 64 Riv when I accidentally overtightened a nut and broke off the threaded part. See before the rebuild pic and after the rebuild with broken threaded part. What is this part and is there a fix or do I hafto replace the whole piece?
  4. I think it’s wired backwards. Is is it green left, black right? it was clicking when I pushed the horn button on steering wheel...
  5. I’ve Just got the riv back from the mechanic, he replaced the tire rod ends in the ball joints and now the centre link seems pretty solid. thanks for the offer tho
  6. Thanks Jframe i just ordered springs from Coil Spring Specialties
  7. So... it seems that there is only front springs available for my 1964 Riviera. Anyone have a source for rears? Also looks like the centre link isn’t available... just rebuildable The $fun$ continues!
  8. Confirmed. Kinda useless but confirmed
  9. I was crawling under the dash today and noticed a second foot switch (circled red) i know the one on the left is the high beam switch. Any idea?
  10. Can anyone identify what the red and yellow wire is for? theres no wires close to it with that kind of plug
  11. Yep. Looks like the steering wheel button. I suppose I need the special puller to get the wheel off
  12. I’ve been using Marvel Mystery Oil in my 47 Plymouth for years. A little in the fuel and a quart in the engine with the regular oil really helps keep the old components running smoothly. Now Im wondering if anyone is using it in their 1963-5 Rivieras
  13. Horns work with 12v put to them. Installed a new horn relay and it does not click when horn button pushed. Arrg
  14. Replaced the horn relay, horn still doesn’t work. Any ideas where to troubleshoot? 64 Riviera thanks