Jump to content

Cruise control stops working after awhile


Guest
 Share

Recommended Posts

I am new to this site. My cruise control on my 1989 just stops working after a few hundred miles. Its almost like it gets too warm. It only happens on longer trips. Is this common? Thank you.

Link to comment
Share on other sites

Guest wally888

A repeat! I am still trying to repair my Cruise C.(89) No voltage in Brown wire at pedal switch,cked all hoses,ran diagnostics but am sent back to previous test(merry-go-round).Anyone know where elect. supply is for brn. wire?

Link to comment
Share on other sites

This car has over 6 pages of tests for cruise control. The cruse control is controled by the body computer. Any body computer codes? I don't know of many BCM failures. The servo looks like a common GM part and could be a possibility. First look for cracked, loose, or missing vacuum hoses under the hood. The turn signal levers (common GM part) do go bad. Eather they have bad contacts or the tiny wires in the column fail. Try moving the turn signal lever and tapping on the switch to see if the trouble comes up. If so replace it.<P>Tom

Link to comment
Share on other sites

I have an 88. my cruise also just cuts out on long trips also, but I have a second problem, My dash switch also goes off by itself and is hard to imposible to get to reingage. all my vacuum hoses were checked and were fine. I was told, to have it checked and fixed could be big $$. Any info would be greatly appreciated.

Link to comment
Share on other sites

Thats exactly what happens to my 1989--the switch on the dash refuses to stay engaged, like it gets too hot. The little LED light will not stay on, thus the cruise won't work.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...