Jump to content

´39 Zephyr speedometer is noisy


181
 Share

Recommended Posts

Being a newbie I guess I will ask before I start taking anything apart and breaking things. My ´39 speedo behaves nicely up to about 45-50 mph, when suddenly I get some continuous rattling/whirling noise from the back of the head unit? As soon as I back up under about 45-50 mph, the sound goes away. What is the suspect here? 

 

The car has a Columbia 2 speed if this changes anything. 

 

Any advices much appreciated! 

 

Jan 

 

Link to comment
Share on other sites

  • 2 months later...

Hello, this is the first time I´m going to poke around the speedometer in my new Zephyr.  What is the easiest way to get to the cable and speedo mechanism? I guess it is to remove waterfall sheetmetal and then access from the underside of the dash? Thank you! 

Link to comment
Share on other sites

On our 48, you have to get really uncomfortable and lay on your head, reach up behind the dash and unscrew by hand the retaining cap from where the  cable goes into the speedo.  You can then pull the cable down and pull out the inner cable, might be easier if the lower end is also disconnected.  I suspect yours is similar.  Sometimes there is wear in the speedometer itself. and you'll need to locate an instrument repair specialist.

Abe

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...