Jump to content

Recommended Posts

So i collected some courage and redid my whole wire harness. Now somehow I managed to rebuild all if it and did an install and the car worked. Even the dash electronics. So just wanted to take it out again to tape it all and noticed that only my brake lights didnt work. I found out the problem was that the big connector was not fully closed and was shorting on the dash. Now if i put a screwdriver on both contacts on the brake switch my brake lights work nicely again. But not by pressing the brake pedal. Did i damage the inside of the brake switxh with the shorting?

 

thanks for you input 

Link to post
Share on other sites

It would be helpful to know what year and model of car you are working on.  More than likely your switch is out of adjustment.  While working around your switch you may have moved it just enough to get it out of proper alignment.  

Link to post
Share on other sites

Did you at any point loosen or try to replace the stop switch? Because those things need to be bled. If air gets in the stop switch the brake light won't work because the air in the switch compresses. If that's it, you need to loosen the switch bolt, step on the brake a little to push the air out, and tighten it again.

Link to post
Share on other sites
On 3/23/2021 at 10:17 AM, Morgan Wright said:

Then the switch is probably busted. Bob's sells them.

Yup. Got a new switch. For buick i cannot find the easy in europe. But these are the same as a willys jeep. And we have plenty of them here haha

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...