Jump to content

Distributer Woes


Recommended Posts

Hi guys.  I finally got my 1929G Graham Paige model 612 running thanks to a carb rebuild.  But now I'm having some other issues with what I can only assume is the timing.  I bought a timing light and hooked the inductor to number 1 spark plug.  When the car was idling away, the timing spot on my flywheel marked "SP FA" which I assume is "spark, full advance" was lit up by multiple flashes from the timing gun.  I made a video that shows the car idling and a close up of the timing mark lit up on the flywheel.  If you look near the end of the video, the mark (highlighted by a piece of green masking tape) is wandering all over the place.  I don't get it.  Is my timing gun flashing multiple times and at the wrong moments or is the timing actually "off".  I assume the timing is off because I'm getting a lot of shaking of the car and funny burping/almost backfiring noises.  

 

Here's a link to the video that shows the issue...

 

https://youtu.be/rVflB9d_9Qc

 

I'm wondering if it's an issue with the centrifugal advance on the distributer going wrong.  I can't figure out what else it could be.  No matter how carefully I adjust the distributer head back and forth, the light continues to dance around the mark flashing multiple times.

 

You guys ever experienced this?  Should I pull the distributor and try to rebuild it again or is that not the issue?  

 

Thanks for you help and remember, I'm a newbie!  

 

Geoff

Edited by GrahamPaige29 (see edit history)
Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...