Jump to content

Recommended Posts

Hello all. My name is Mike. I just joined this forum. I have been a car guy my whole life (52yo) My focus is early Fords, 32 - 40 being my target years. I have a few old Ford's ranging from completely stock to 50's Hot Rod. My wife and I enjoy the cars and travel in an old car whenever possible.  

I recently bought a 1912 Buick Model ?  28 or 30. I have ask a few others and strangely enough I haven't recieved a definitive answer.  The previous owner unfortunately passed away so the car information went with him. The car is amazing to me and I am looking forward to enjoying it. I need a fair amount of help as I know nothing about the car but I certainly look forward to learning.  

 

20200730_140714.jpg

Edited by 1932V8 (see edit history)
Link to post
Share on other sites

Thanks, Ed, but I’m no “expert” by any means.

 

The only early Buicks about which I can hold my own are 1909-10 Model 16 and 17.  In fact, I’m updating the roster for those two models only, if you have one and I haven’t been in contact with you lately, please get in touch.  David.coco@comcast.net

Link to post
Share on other sites

1932V8:

 Congratulations on your NEW BUICK! 

The stance and details on this car tell me it is a 1913 Model 30

 The Model 30 should have a 108" Wheel Base. Originally offered in Blue-Black or Gray.

 Let us know where you are located for local help. And more pictures.... We love pictures!

  • Like 1
Link to post
Share on other sites

Congratulations on your new car. Where are you located?  Your car has the same engine as my '13.  There are a number of us that have that car.  Another persons that has LOTS of experience with that engine is Mark Shaw.  Both he and I tour our cars quite a bit.  Let us know what you would like to know.

 

PS: only post a question one time, not in three different places.

Link to post
Share on other sites

Thank you Larry Schramm. I posted first in this introduction forum.. then I thought I made a mistake and I should have just introduced myself here and then made a post in the Pre War forum, so I did.. I apologize for the confusion.  I will make sure I only post my questions one time and in the correct forum which I believe is the Pre War forum..

Thank you

  • Like 1
Link to post
Share on other sites

Us guys on the Pre-War group are the best at helping each other.  You might also go the Yahoo Brass Buick Group and join that group.  We are very active in helping each other there and there is a lot of discussion on our cars.   Just go to Yahoo and search Brass Buick and ask to join the group.

  • Like 1
Link to post
Share on other sites
14 hours ago, 1932V8 said:

Thank you Larry. I went over to BB@Brass Buicks and joined. I will start asking questions soon. Do you think that BB site is the better place for questions? 

Thank you 

 

More activity on BB, but both places are good.   Also, where are you located?

Link to post
Share on other sites

Hey Marty. I am in Northern CA.  1 hr North of San Francisco in a town called Windsor. 

At this point the car has no spark. It has a Bosch magneto. I have pulled apart the point end of it and will clean it and check the points and the gap... then I will go from there and see what I have 👍

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...