Jump to content

Recommended Posts

My TC has a brake issue. When I'm coming to a stop, just before completely stopping, I hear a clunk and the pedal drops and goes soft. Pumping them again helps. Hitting them hard or at speed causes no problem, it only happens at very low speed. When I start of again they're fine until I am almost at a stop again. Any ideas? 

Edited by 2Shelbys (see edit history)
Link to post
Share on other sites
  • 1 month later...
On 8/28/2020 at 7:37 PM, 2Shelbys said:

My TC has a brake issue. When I'm coming to a stop, just before completely stopping, I hear a clunk and the pedal drops and goes soft. Pumping them again helps. Hitting them hard or at speed causes no problem, it only happens at very low speed. When I start of again they're fine until I am almost at a stop again. Any ideas? 

What is the condition of your Accumulator?  I ask this because so many TCs are still running around with their original accumulator. Has yours ever been replaced?

  • Like 1
Link to post
Share on other sites
On 10/7/2020 at 5:38 PM, Hemi Dude said:

What is the condition of your Accumulator?  I ask this because so many TCs are still running around with their original accumulator. Has yours ever been replaced?

Mine has been replaced and I have a spare. In fact, the entire TEVES unit still looks brand new. I hadn’t posted it yet, but I cured this by simply bleeding the brakes. The fluid was pretty dark and there was definitely air in the system. 

  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...