Jump to content

Recommended Posts

The last couple of months I have been trying to get my 38 to start again since I got it started last summer.  It wouldn’t turn over completely and I figured out that the inline fuel filter my guy had put in was crimped.  I bought a couple of gallons of gas and a new filter.  I started it up, the choke stuck, and the engine ran high longer than I wanted it.  Next thing I know, there’s coolant dumping out of the radiator.  What a disaster!

Link to post
Share on other sites

How do I get the choke to release?  It’s stuck out halfway.  It will come out more but it will not go in past that point.  It’s like something solid dropped down and it is stopping it from going all the way back in.

Link to post
Share on other sites

The cable and the butterfly can be adjusted independently but the slide on the dashboard is what is sticking halfway out.  It won’t go back in and I don’t want to force it.

Link to post
Share on other sites
7 hours ago, 38ShortopConv. said:

Lift the choke slide up a tad, should push in. There is a slight  step underneath possibly  for fast running? Otherwise inner cable could be snagging further in against outer sheath.   

I did check out your suggestion.  There doesn’t seem to be a step but the cable might be hanging up before that.  I’ll check the cable out.  Thank you, I appreciate it.

Link to post
Share on other sites
On 6/29/2020 at 7:08 PM, 38ShortopConv. said:

Remove right side off center consul. Check choke cable outer sheath  is not sagging stopping inner cable from sliding thru. Outer sheath should be anchored at choke slide end. 

It looks like that might be the issue.  It’s a nest of wires in there!  Not to mention, it’s just about impossible for 6’6” guy to contort himself to where he can get at it!

Link to post
Share on other sites

I have not.  I wanted to get in behind to see if anything obvious stuck out.  Everything was working fine up until 2 weeks ago.  Someone recommended making sure the cable sheath was still intact and it looks as though it is.  The cables look okay but it is an 82 year old car.  I am pretty sure they are original.  
I pulled the throttle out to see if the choke would go back in all the way and it is stuck out too.
It seems like the slides for the choke and the throttle are getting jammed at a certain point like something might have dropped down.  Could too much tension on the cables cause this?  I guess I should go ahead and disconnect the cables and see what happens.

Link to post
Share on other sites
Posted (edited)

Yes you can disconnect both cables at the carburetor  end, just release the spring  clips Then you can check if  choke and throttle can move freely at carburetor. If they do then you can go back to the cables and slides. .I see the light switch and cig. lighter have been replaced, Theres a silver strip showing on top of light switch, doesnt look right, something in there could be catching?  Once you disconnect the cables at carb end the knobs should pull out a bit further to see if anything has dropped down and snagging . Happy Dayz.

Edited by 38ShortopConv. (see edit history)
  • Like 1
Link to post
Share on other sites
11 hours ago, 38ShortopConv. said:

Yes you can disconnect both cables at the carburetor  end, just release the spring  clips Then you can check if  choke and throttle can move freely at carburetor. If they do then you can go back to the cables and slides. .I see the light switch and cig. lighter have been replaced, Theres a silver strip showing on top of light switch, doesnt look right, something in there could be catching?  Once you disconnect the cables at carb end the knobs should pull out a bit further to see if anything has dropped down and snagging . Happy Dayz.

Thank you.  I was going to figure out where that light went after this.  I turned the center console on at night and it doesn’t seem to be a backlight for any of the instruments.  The ashtray on the right was pulled out so we could monitor oil pressure digitally.  Is it for the ashtray?  I am going to tackle it tomorrow.  It’s been awfully hot here!

Link to post
Share on other sites
Posted (edited)

Just for the record its wet cold and windy here. Our winter. Theres about 3 or 4 cluster lights at the back of speedo on my 38, they come on thru head light switch, there is a dimmer switch bottom edge of dash. Could shine light down open air vent .Over and Out.

Edited by 38ShortopConv. (see edit history)
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...