Jump to content

When I apply the brakes the button lights on the CRT change


DarrenG
 Share

Recommended Posts

Hi All,

I have a weird one and I could not find an existing thread for. After my 1989 Reatta warms up, when I apply the brakes the button lights on the CRT change  from summary to one of the other lights but the display does not change and the chime starts to scream until I lightly tap the dash above the CRT then it stops, until I push the brake pedal again? I have a video but it is too large to attach I will take shorter one with lower res and see if I can download it.

I have also changed the CRT cluster with one from a different car but the problem remained.

Also when I do apply the brakes the car runs rough and while holding the brakes on if I push up to close the window with the window already closed the car idle gets even worse.

I did clean all of the contacts but the problem still persists, when I changed the EBCM it did change the way the lights and the screaming acted with one EBCM it is every time the brakes are applied and with the other one it is when the brakes are released but a bit more intermittent.

Anyone know of a EBCM rebilder?

Edited by DarrenG
ECBM not BCM (see edit history)
Link to comment
Share on other sites

18 minutes ago, DarrenG said:

when I apply the brakes the button lights on the CRT change  from summary to one of the other lights but the display does not change

 

I've not heard of this before.  Do the brake warning lights on the instrument panel come on when this happens?

Link to comment
Share on other sites

25 minutes ago, DarrenG said:

Also when I do apply the brakes the car runs rough and while holding the brakes on if I push up to close the window with the window already closed the car idle gets even worse.

 

That sounds like you might have an electrical problem that might be caused by a bad ground or a bad alternator.  Try switching the CRT to the gauges screen and watch for a drop in battery voltage when you apply the brakes.  That might give you anindication of what's going on.

Edited by Ronnie (see edit history)
Link to comment
Share on other sites

6 hours ago, Ronnie said:

 

I've not heard of this before.  Do the brake warning lights on the instrument panel come on when this happens?

Hi Ronnie,

no the brake lights do not come on I wish I could attach a larger file to show the video.

 

6 hours ago, Ronnie said:

 

That sounds like you might have an electrical problem that might be caused by a bad ground or a bad alternator.  Try switching the CRT to the gauges screen and watch for a drop in battery voltage when you apply the brakes.  That might give you an indication of what's going on.

Changed the alternator and have cleaned every ground point on the car but I will check the gauges and it is only when the car warms up not when it is cold.

 

5 hours ago, DAVES89 said:

Or you have bad connections on the wires under the carpet in front of the passenger seat.

That I will have to check for.

 

Link to comment
Share on other sites

Just now, Ronnie said:

You have a really unusual problem. I wish I had more to offer but nothing comes to mind. I can't think of why the problem would be related to the engine warming up.  Checking the connections as Dave suggested might fix the problem. 

check out the video you can hear me pressing the brake pedal.

Link to comment
Share on other sites

Where did you get your BCM from and did you swap the prom from your car into the "new" one? Just as a thought if the BCM came from a salvage yard try that prom into your car.

 I have tested BCMs on the shelf [for sale] and they also have Reatta proms. Maybe give me the prom number as well. Mileage will be different but it should work.

Link to comment
Share on other sites

 

9 hours ago, DAVES89 said:

Where did you get your BCM from and did you swap the prom from your car into the "new" one? Just as a thought if the BCM came from a salvage yard try that prom into your car.

 I have tested BCMs on the shelf [for sale] and they also have Reatta proms. Maybe give me the prom number as well. Mileage will be different but it should work.

Hi Daves89, Sorry I replaced the EBCM(electronic brake control module)  not the BCM(body control module) I will edit my post. Do you have a EBCM?

Thanks for your help.

 

9 hours ago, Ronnie said:

Have you tried entering diagnostics to see if there are any CRT, IPC or BCM codes?  How To Access ECM, BCM & CRT Codes

Hi Ronnie, Yes and there are no codes this is a weird one for sure, I will have to do a deep dive of all the relays and wiring.

Thanks for your help.

Link to comment
Share on other sites

On 11/10/2019 at 12:27 PM, DarrenG said:

when I apply the brakes the button lights on the CRT change  from summary to one of the other lights but the display does not change

 

I would disconnect the brake light switch at the top of the pedal.  If the problem persists you will know it's caused by the brake system. If the problem goes away you will know it's caused by the brake lights. Does it happen if you turn the emergency flashers on or the turn signals?

Link to comment
Share on other sites

4 hours ago, Ronnie said:

 

I would disconnect the brake light switch at the top of the pedal.  If the problem persists you will know it's caused by the brake system. If the problem goes away you will know it's caused by the brake lights. Does it happen if you turn the emergency flashers on or the turn signals?

I will check it the next time I am out.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...