Barney Eaton

Reatta headlight

Recommended Posts

Just wanted to thank everybody for their help. I found the module and the wire and cut and capped the wire going to the headlight switch and led the wire from the module up to a factory ground spot. Headlights work like they are suppose to. I installed a fuse in the ground wire just in case. Probably no need to do that but just in case lol. I'm sure I'll be back for some more questions! Also there was another spot on this website that mentioned the 5 or 6 splices under the passenger side carpet that go bad and wasn't allowing my dome lights and a few other things to work. I got that mess straightened out to! You guys are awesome! Thanks again!!

  • Thanks 1

Share this post


Link to post
Share on other sites

There are splices under both seats with similar issues. If seemingly unrelated things don't work, especially on the drivers side, take a look under the other seat. I had drivers door courtesy lights, door locks operated by the trans shifter and the trunk lock at the rear, sure looked unrelated to each other but thanks to this forum, I found the problem. Oh yeah, I think the inner rear turn signal/brake high filament light bulb didn't work on each side either. The 90-91 rear flasher system is different in that the outer two turn signal bulbs are operated from the dash area as usual, but the third bulb, the inner one, is operated via a relay inside the trunk on the passengers side front. If no power gets to the trunk mounted relay, the third bulb on each side won't flash.

Share this post


Link to post
Share on other sites

See here. Fifth picture down.

Share this post


Link to post
Share on other sites

Yup. I tore the interior out and had to redo every single splice pack on passenger side. All driver side ones were good. My car had damp carpet and took 3 days to dry it out with a furnace blower lol. Now I’m sure it’s on here somewhere and I’m not seeing it but now the next task is the cruise control. It doesn’t work at all and when I first got the car, I could read codes by using the off temp up buttons but now it won’t let me do that. So I got into the bcm with my scanner and it shows the cruise switch and all of its buttons working as well as the brake switch turning on and off. So I went out to my parr’s reatta and took the cruise servo out and swapped them but still doesn’t work. Nothing happens when I hit the cruise. No lights no nothing. 

Share this post


Link to post
Share on other sites

This may be weird to most here but on the just departed Black '89 my cruise stopped working. I swapped out servos [I had 5 of them] and no luck. No codes either, but on a whim i swapped out the headlight switch and the cruise worked.

Share this post


Link to post
Share on other sites

Just a note but many things can cause the cruise to drop out. Was driving my 90 Bonneville up north and when the outside temp hit 45F the cruise suddenly dropped out. Seems the thermostat was stuck open and when the coolant dropped below 158F, it went open loop and the cruise control dropped out. Never a problem in Florida because was garaged.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now