Summershandy

Brake light mystery

Recommended Posts

Checking my brake lights today with the wooden stick holding down the brake pedal and I noticed the drivers side out. Bulb is good, socket is good. Tail lights work. I noticed the PO marked the wires in the trunk with tape. The brake wire is also the signal wire. Well, I shouldn't have a signal light then. I turned on the signal and it was blinking. Went to turn the signal indicator off and when I went back the brake light had came on. Almost like the signal light gave the brake light a kick in the arse to turn on. I'm wondering what that's all about? The engine wasn't running in case that has an effect.

Share this post


Link to post
Share on other sites

Sounds like your turn signal switch needs cleaning or replacing, the brake lights depends on the turn signal switch being in good condition. 

  • Like 2

Share this post


Link to post
Share on other sites

On a car that shares a bulb between the turn signals and brake lights, this is a common problem. Wiggle your turn signal stalk and it will probably come back. The most likely problem is the turn signal switch.

 

Heres how it works: The brake light circuit runs through the turn signal switch. When you turn on a signal, one set of contacts connects a front signal to the flasher, and another set DISCONNECTS one brake light bulb and connects it to the flasher. It should connect that bulb back to the brakelights when the turn signal cancels, but don't bet on it with an old switch.

Share this post


Link to post
Share on other sites

Thanks guys good to know! At least I've got something to go by. One day I'll get the steering wheel off to clean and inspect. 

Share this post


Link to post
Share on other sites

In the meantime you can try shooting some WD-40 into the switch mechanism using the nozzle straw.  Work the switch up & down a few times and see whether behavior improves...

Share this post


Link to post
Share on other sites

Hi Mark.  Have a turn signal/brake light issue also. Park lights work. Headlights work. Turn signals flash but weak and fast. One side only. Harness is off now and I found this.. wire rubbed through on top of fan shroud... Might want to check yours.... Like cars may have same issues.... John

IMG_20190810_140551400.jpg

IMG_20190810_140342628.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...