JBuick

1921 buick 21-44 roadster - waterpump

Recommended Posts

Thanks to Hugh for advice on reposting to this page!

 

Hello out there,

 

I’m the new owner of a 1921 buick 21-44 roadster. I do most of my own work. I am going through the car fixing and rebuilding different major components. I removed the water pump cleaned up the shaft and repacked it. Shaft is in so-so condition, and I never actually took the water pump itself apart.  Given the large chunks of rust that came out of the block etc. and the condition of pump body, I would like to find a rebuildable core. Or does anybody know of someone who can make/reproduce the shaft? Or if someone had a technical drawing of it, I’d take a crack at making it myself. Any leads on axle and trans seals would be much appreciated. Appreciate the help. Love the pre-war cars!

049F1A27-49A8-4ED4-A1ED-5EE7375DC733.jpeg

  • Like 4

Share this post


Link to post
Share on other sites

I have been involved in fixing a number of water pumps.  Look here for how to fix them.

 

Where are you located?

 

 

  • Like 1

Share this post


Link to post
Share on other sites

That is a really good-looking roadster.  I especially like the top.  I'm crazy about the pre-war Buicks also.

 

Terry Wiegand

South Hutchinson, Kansas

Share this post


Link to post
Share on other sites

J Buick

     Welcome to the Pre War Buick group.   Here is my note regarding felt seals (as used in the Back axle).  

 

George – Makes Felt Seals, in North Carolina    910-693-3324

 

I have converted most of my felt seals to using lip seals (with a spring).  That is your option to stay with felt or modernize. 

Keep in mind that many of the guys on this site have been down the path you are on.  My experience is that the more pictures you post of what you need, the better the response you will get.     Hugh

 

 

Share this post


Link to post
Share on other sites

Hi Guys,

 

Thanks so much for the welcome! And thanks Hugh & Larry for the very complete instructions & detailed pics. I’m on the central coast in California. This is my first pre-war car, and I’ve got the bug bad! Got it up to 45 mph a couple days ago. Engine could have gone another 5 easily; tires and wheels, not so sure! 35 mph seems like the sweet spot to me. Split rim tire changing here we go. Tuned the Marvel carb to 16 on a temporary teed off vacuum gauge, as I am at sea level here. Engine has plenty of smooth off the line torque. When I got it, Starter/generator motoring was disconnected. When connected, it turned backwards. Main positive power post bracket was twisted up catiwompis and shorting against the field coil. Rectifying that was the fix. Last owner wired a second battery in the trunk. Still 6v system. Any idea why? (There were LED rope undercarriage lights, which I ditched.) Anyway, more fun each time you fix something. 

 

11C36E06-EF58-42F7-AAAB-B8F607004646.jpeg

  • Like 2

Share this post


Link to post
Share on other sites

6 volt system is fine and there is no need to change it to 12 volts.  All you do is make the car harder to fix, plus changing all of the bulbs, etc.  Just make sure that the wiring is in good condition and everything will work well.  The car is a negative ground.

 

Your car may be able to go 45, but remember that it only has rear brakes.  Works OK, but you will need to become a driver that "drives" a couple of hundred yards ahead if not further trying to anticipate what stupid people will do cutting in front of you and slamming on their brakes.  My cars of that age also have a "sweet spot" of about 30-35 MPH.  If you push it too hard too long, things will just break. 

 

Drive slower and enjoy the ride.

  • Like 4

Share this post


Link to post
Share on other sites

JBuick.....I had the same model nice car I sold it few years back.  On one of my spare engines the water pump shaft had been cut and a new piece added....they retained all the complicated parts of the shaft assossiated with the gear and bushing and simply replaced the straight 3/4 shaft through the pump.   the new shaft and old shaft were coupled with a keyed coupler.  Note on the 1921...they were cutting corners that year and it is required to oil the sleeve bearing coming out of the water pump gear every 500 miles.  I went about 700 miles and the shaft tied right up.   I eventually remedied the situation using a bearing sleeve from a 1923 pump. It had a slinger ring in it that promoted proper lubrication.  Have fun with your car, keep it at or under 45. It will go faster but why push the old girl

113-1393_IMG.JPG

21 piss poor oil hole.jpg

113-1338_IMG.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Hi Tblack,

Thanks for the good info and pics! I have seen pics of the car you sold while surfing the net for references. It was one of the inspirations for buying mine. I can’t say enough how as to the value of the my particular Buick, it’s great to be part of club that’s motivated from love not speculation! To me it’s about actually driving them and keeping them road worthy. 

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, JBuick said:

To me it’s about actually driving them and keeping them road worthy. 

JBuick,

    You are in very good company here...  Larry's advice on 6V systems is right on, but just make sure you have 00 battery cables for your 6V system.  Modern 12V cables will not cut the mustard.  I also got a kick out of your "catiwompis" terminology.  I haven't heard that term for a long while...

Enjoy the ride...

  • Like 2

Share this post


Link to post
Share on other sites

Mark,

 

That phrase is what we folks out here in Doo Dah refer to as a 'euphemism'.

 

Terry Wiegand

South Hutchinson, Kansas

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now