mytc05

Power/alternator problems

Recommended Posts

Hey all,

Pretty sure my alternator has gone bad. We replaced the battery a while back because of it frequently going dead, and while that indeed might have been part of the issue, it's still going dead with the new battery. So, I'm pretty sure it's the alternator. The battery level indicator is not reading in the middle like it used to, and sometimes, even while driving it for a while, it doesn't get back up to the fully charged spot. Then, when I shut the car off and come back later, it's dead again. Planning on taking it up to the parts store to get it tested. Would prefer to get a Chrysler OEM replacement, but not sure how expensive that's going to be yet. Have any of you all replaced the alternator on our TC's before, and if so, do you remember the cost and where you got it from?

Share this post


Link to post
Share on other sites

If it looks like this one, you didn't mention a year model, all you need to do is replace the brushes.

IMG_0402.thumb.JPG.c82ce1ea7017d3390c04b3404b244d66.JPG

On 2/17/2018 at 11:05 AM, tjackmil said:

My PA registration shows

        YR/MAKE:     1989 Maserati

        TYPE:             Conv

 

Share this post


Link to post
Share on other sites

Hey Hemi. Realized I never responded to your comment on this. Thanks for the info. We ended up just replacing the alternator with a new one, and it took care of it. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now