Sign in to follow this  
tcmark

top release problem

Recommended Posts

I put the top up last Friday so I could wash the car.  The back posts were locked in place when I pressed the motor switch.  I secured the front j-hooks.  This morning, nothing happens when I push the top switch to release the back posts.  There is no sound from the area around the switch.

 

I would appreciate hearing ideas of what the mechanic should be sure to check.

 

Thanks,

Mark

Share this post


Link to post
Share on other sites


Benefits of AACA Membership.

2 hours ago, tcmark said:

I put the top up last Friday so I could wash the car.  The back posts were locked in place when I pressed the motor switch.  I secured the front j-hooks.  This morning, nothing happens when I push the top switch to release the back posts.  There is no sound from the area around the switch.

 

I would appreciate hearing ideas of what the mechanic should be sure to check.

 

Thanks,

Mark

First, I would check the switch. Often owners seem to have a problem releasing the back posts.  You did of course press the upper part of the rocker switch to release the top??? 

If nothing works, the 2 switches there, besides each other, are EXACTLY the same part number, so you could try switching the wiring connector for the pull-down mechanism to the tonneau cover switch and if the motor now works correctly using that switch, you would merely need to get another switch.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Hemi,

Thanks for the help.  I waited to respond until mechanic checked and reported that fuses are ok and switching wiring connectors did not get pull down motor to work.  He says he is not comfortable doing any other electrical investigation.  He commented that the service manual I provided did not give much info about the relay switches.

 

After asking around, I have another lead for a mechanic who might be able to help.  Could you please tell me where do get more specific information about the relays, motor and any other helpful info.

 

Thanks very much,

 

Mark Greenberg

Share this post


Link to post
Share on other sites

Unfortunately the FSM is one of the best resources there is. Being as this is a GM part, you may be able to reference GM literature that may be more detailed. 

 

My bet is that the gearbox is gummed up and the motor is stuck. The best thing you can do is have the entire mechanism removed and work on it outside of the car. It's 5 10mm nuts. Takes about 10 minutes to remove. To put it back in you have to realign the pin latches. This is mostly a vertical adjustment and can take a few times to get right.

Share this post


Link to post
Share on other sites

Hi Mark... there is an alternative available, if you can't find someone to work on your mechanism. Try contacting tcparts.com., they will rebuild your unit. Albeit on the expensive side but a certified mechanic doesn't come cheap either. If your not really comfortable with trying to fix it yourself this could be another route for you. Good Luck

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this