Jump to content

Brake problem-Locking up wheel-37 Packard 120


Recommended Posts

I have a 37 Packard 120 and am having problems with the brakes locking up.  A very experienced mechanic rebuilt the entire brake system all the way from master cylinder to each and every wheel.  He said the set-up process was very difficult.  He followed the set-up and adjustment procedures as outlined in the Packard shop manual yet as he set things up, one by one he had to work at extensively adjusting each wheel because first one would lock up and then another and then another.  Thought all were good to go and the car drove well for 100 miles and then this year for no apparent reason, the left rear locked up when coming to a stop at a light.  More adjusting and seems to be working but based on its history, not confident the problem won't come back at the worst possible time.  Has anyone had this problem?  Is there a trick to setting up the brakes?  As I mentioned, everything is new in the entire system.  Any input would be appreciated.  Hard to find people who still work on these older cars.  Thanks, Bob

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

That looks to be a fairly standard brake system. Did you arc the shoes to be certain that the curve of the shoe matches the curve of the drum? Are the drums REALLY clean? Are the shoes REALLY clean? Have you bled all of the brake wheel cylinders from the farthest away from the master cylinder and working your way to the front? Sorry for the simple questions, but there are only so many things to check here. What is your location? Maybe a member near you can help. 

Link to post
Share on other sites

I always adjust the shoes to BARELY rub the drums. If you spin the drum and hear rubbing a little, that is fine. If you spin the drum and you hear intermittent rubbing, the drums may have to be turned. Be sure the brake shoes are seated in the right spots and centered on the backing plate.

Edited by keiser31 (see edit history)
Link to post
Share on other sites

Looks like the edges of the linings were not beveled. If so, that can cause "grabbing" with self-energizing (single anchor) brake systems.  You can bevel them on the car with a wood rasp file.

 

Paul

Link to post
Share on other sites
3 minutes ago, PFitz said:

Looks like the edges of the linings were not beveled. If so, that can cause "grabbing" with self-energizing (single anchor) brake systems.  You can bevel them on the car with a wood rasp file.

 

Paul

YES! I forgot that part. That would be the ends of the shoe surfaces.

brakeshoes.jpg

Edited by keiser31 (see edit history)
Link to post
Share on other sites
35 minutes ago, keiser31 said:

YES! I forgot that part. That would be the ends of the shoe surfaces.

brakeshoes.jpg

 Thank you Keiser - yes, just bevel the ends, not all "edges".  

 

Had just finished another post about oil/grease seals and must had the word "edges" still on my mind.

 

Paul

Edited by PFitz (see edit history)
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...