Sign in to follow this  
dbaker9323

Aftermarket Cruise Control Kit - 65 and 66 Riv

Recommended Posts

I am looking for the best aftermarket cruise control kits to purchase for my 1965   (401)  and 1966 (425) Rivieras.  They were not equipped with factory cruise.  Can someone direct me to the best and easiest to install products?  Thanks

 

David Baker

ROA 14360

1965 Buick Riviera.JPG

Baker 1966 Buick Riviera for Hagerty.JPG

Share this post


Link to post
Share on other sites

Talk to these guys:

 

http://www.rostra.com/universal-aftermarket-cruise-control-by-rostra.php

 

They do not have a unit list explicitly for a '65 or '66 Riv, but I suspect hey can help you work something out.

 

I have a unit like theirs on my '63.  You put magnets on the driveshaft with a coil pickup (for road speed).

 

The engine has so much power that, even on the lowest sensitivity, it really jumps up in speed when it falls the least bit behind.

 

 

  • Like 2

Share this post


Link to post
Share on other sites

I installed a Rostra unit I bought from Dakota Digital. Good instructions made the installation pretty easy. Now, instead of magnets on the drive shaft, they have a pulse generator which installs at the speedometer cable at the transmission. Had mine for five years.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, johnrex said:

I installed a Rostra unit I bought from Dakota Digital. Good instructions made the installation pretty easy. Now, instead of magnets on the drive shaft, they have a pulse generator which installs at the speedometer cable at the transmission. Had mine for five years.

 

I've installed the same unit on 3 of my classics, the latest being my '65 Riv. I would agree with johnrex on all of the above and Jim in the exemplary way they perform.

 

Steve

Share this post


Link to post
Share on other sites

Love the Dakota Digital version on my Electra.  So much smoother then the factory cruise on my Rivera. That was speed up / slow down / speed up slow down. A friend swore he would never ride with me again because it made him sick.

Share this post


Link to post
Share on other sites
41 minutes ago, Bill Stoneberg said:

Love the Dakota Digital version on my Electra.  So much smoother then the factory cruise on my Rivera. That was speed up / slow down / speed up slow down. A friend swore he would never ride with me again because it made him sick.

 

Well,  mine did that when I got it.  Then I fixed it.  It doesn't do that anymore.  What it does do is accelerate to speed faster I do using my right foot.

Share this post


Link to post
Share on other sites

Kongaman 

what was the fix for the factory cruise? 

I have a new Dakota digital in the box. I now own Bills Riviera and the factory cruise quit working completely. The amplifier is a vacuum tube unit and my guess is the tube and potentially capacitors are shot. The green CRUISE light illuminates but nothing will engage. 

The servo is connected both physically and electrically me it has proper vacuum, brake switch is good, no leaks. The speedometer Head is good and the contacts are working as designed. No blown fuses. I’m 99% the amplifier needs a rebuilt which isn’t hard to me since I’m an electrical engineer. Just not sure its worth it vs installing the Dakota Digital.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this