Joe Cozza

Infor on a Delco generator on a 31 DB

Recommended Posts

Hi All,

Just came back from a car show and noticed that my gen. wasn't charging. It would discharge with the lights on , but would not charge when I raced the engine.

I checked and the fan belt was tight.

Can somebody give me some ideas as to what also to check before I give up and send it out .

Also ,who is a good shop to send it to in or around CT or the northeast for that matter.

Thanks,

Joe C.

Share this post


Link to post
Share on other sites

1)  Hook up a good external meter to verify that the gage is correct.

2)  Check all circuit connections and wires.

3)  Verify that generator brushes are;

      a )  making contact (brush springs not broken or weak)

      b )  not excessively worn

4)  Verify operation of cut-out (see if charge is coming out of generator, and through cut-out to battery)

5)  If all checks well, have generator shop test generator output before re-winding.

 

Share this post


Link to post
Share on other sites

The generator on my '33 stopped working like that. I took a jumper wire and touched both terminals of the cut out together momentarily. The unit started working again and is still going. As I understand it, the generator can lose its charge and the jumper wire trick resets it. Cheap and easy fix. Zeke

Share this post


Link to post
Share on other sites

Hi All,

I have a update on my generator problem. I looked on the Dodge

Brothers preferred vendor list and found  A&S Ignition Inc. in Patterson NY It was 1 hr. away. A phone call was made and they were willing to look at it.

To make a long story short, they checked it out took it apart while I was looking on and he noticed a bad brush and the commutator was out of round. I went back the next day and picked it up .The cost to replace all three brushes and to turn down the commutator was $65.00 which I thought was very reasonable.

During the winter months I'm going to bring my starter to him and have him go through it also.

BTW: I installed the gen. and it's working perfectly.

Thanks to those who commented on.

Joe C.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...