Jump to content

Speedo error


wheelsport

Recommended Posts

My speedo reads high (60mph actual - reads 75) I bought the speedo head from a wrecker and I'm not sure

what it is actually out of. It is identical to the original other than the error. I know that there are

several MOPAR cars that use this speedo. Could the one I have, have different gearing inside and isn't

truly compatible with my car? Could a dirty speed sensor cause error in the speedo? Hemi suggested to move the needle to stop, when parked, lower than zero. I don't think changing sensor gears would do anything but give odometer error.

Link to post
Share on other sites

My speedo reads high (60mph actual - reads 75) I bought the speedo head from a wrecker and I'm not sure

what it is actually out of. It is identical to the original other than the error. I know that there are

several MOPAR cars that use this speedo. Could the one I have, have different gearing inside and isn't

truly compatible with my car? Could a dirty speed sensor cause error in the speedo? Hemi suggested to move the needle to stop, when parked, lower than zero. I don't think changing sensor gears would do anything but give odometer error.

If the odometer is reading rather correctly and the speed is 15 MPH off at 60, there is something wrong with the speedometer part. There is not any cure that I can recommend other than having it calibrated by a certified speedometer repair facility. 

 

Tell us, why did you remove the original assembly?

Link to post
Share on other sites
  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...