Jump to content

transmission


Guest rls65rls
 Share

Recommended Posts

Guest rls65rls

took the first ride in the riv, didn't last long the tranny won't shift out of first gear.the tranny has sat for some 20yrs, replaced fluids, tranny filter' etc .what next ? who makes a good rebuilt tranny, or who is a good tranny rebuilder.  lost

Link to comment
Share on other sites

Guest onedesertdog

  1. What Tom said... My 65 which sat for over 20 years, had basically the same issue. After the folks here helped me out with suggestions, I first replaced the modulator. Still the same issue. Next was the vac. hose. Found it to be completely clogged. Replaced it, and she shifts so Purdy.....

Link to comment
Share on other sites

Dittos to above , plus, keep checking fluid level; even after only a short drive down the street.  

If the torque converter was empty and the trans was completely drained….it's gonna take

a bit of circulation to get enough ATF to the converter, pump, valve body etc.

 

I had the same thing happen to my freshly built T400.  I freaked, since it wouldn't shift

after a brief drive down the street.  Ended up I was just low on fluid; even when the initial stick

reading showed full.  Drove it a block or two…. needed another qt. …. etc. till she shifted just fine!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...