Blue1960

383 Engine in a 1960 Desoto Adventurer

Recommended Posts

Hi Guys,

 

I am in Australia and I have only just bought in a 1960 De Soto Adventurer 4 Door, VIN:  7203123314 and it currently only has a single carburetor on the engine. 

What I would like to put on this car is the Ram Induction System. I think it comes with manifold and 2 carburetors (I think they are Carter Carburetors) What linkages are needed to fit it straight onto my engine? Are there any modifications needed to the muffler or intake system to put this kit on?? 

Could we encounter any problems at all in doing this?

What we need now is the manifold and carb kit - Has anyone out there got one and can you give me some idea of what they are worth please?

 

post-153819-0-65586500-1434948802_thumb.

Share this post


Link to post
Share on other sites

Welcome to the forums. And nice car!

 

The original Carter information is somewhat confusing.

 

In 1959, Carter sold to Chrysler AFB carbs number 2790s and 2791s to be used on DeSoto with two 4-barrels.

 

In 1960, Carter sold to Chrysler AFB carb 2903s to be used on Chrysler. There is no mention in the Carter literature if these carbs were also used by DeSoto, but then Chrysler didn't always tell Carter everything they did.

 

In Carter terminology, the "s" in the part number means "assembly". Most vendors will omit the "s" when advertising a Carter carburetor.

 

As far as value is concerned, these carburetor setups are RARE!

 

As far as I know, only one has been on Ebay in the last three months. Here is the ebay auction number: 191567963567

 

You can look at this auction to get some idea of value. Note that the auction was for USED items needing total restoration.

 

Good luck.

 

Jon.

Share this post


Link to post
Share on other sites

This question interested me as I work with a lot of big block Mopars.

There seems to be many choices for the raised block (RB)  engines (413, 440) but these will not fit the 383s or the 400s.

I did find a tunnel ram setup for the low deck engines but you would have to take off the hood.

http://www.summitracing.com/parts/cmb-03-0186/applications/make/chrysler/engine-size/6-3l-383

With some searching you should be able to find an aftermarket dual quad manifold, maybe Edlebrock or the likes.

Share this post


Link to post
Share on other sites

You need to be a bit careful. They actually made 2 different 383 cu in engines that year, a low deck and high deck. The high deck used the taller Chrysler 413 block. They only did this for a year or 2. Almost all 383s are the low deck but yours may be the high deck.

 

The ram induction carb option was very rare, no more than a few hundred sold each year if that. Most people are aware of the intake manifolds and carburetors, and linkage, but they also had special exhaust manifolds for carburetor heat. Carbs and intake manifolds sell for thousands of dollars, more if they come with air filters, linkage, and so forth. Correct exhaust manifolds almost impossible to find.

 

A lot of them were taken off and a single 4 barrel substituted. They were complicated and did not do anything for performance until you hit 80MPH or so. Another problem was poor starting and low speed running in cold weather, which may not be a problem in Australia.

 

I must ask, how much time do you spend with the gas pedal flat to the floor wishing for more horsepower? Unless this is a serious annoyance you would be better off with the stock 2 barrel or 4 barrel setup.

 

Make sure the engine is in good nick (how is compression and oil pressure?) tuned up properly, and that the carburetor is fully open when the gas pedal is down. Unless you are an out and out maniac you should have all the power you need.

 

If you are an out and out maniac there are other mods that will give you more bang for the buck than Sonoramic carburetors.

Edited by Rusty_OToole (see edit history)

Share this post


Link to post
Share on other sites

I don't think the Sonoramic setups came on the Desoto, Only Chrysler.

I think the Desoto dual quads were in line.

After tinkering on this setup for a few years I have it working pretty well.

It will go faster than I have ever driven it.

post-95665-0-35262800-1435764216_thumb.j

post-95665-0-76895400-1435764250_thumb.j

Share this post


Link to post
Share on other sites

There's a fair amount of mis-information above - 

 

The High-deck 383 was not factory installed in the DeSoto,  only on the  US built Chrysler Windsor and Saratoga in 1959 and 1960.   The DeSoto used only the low deck 361 and low deck 383 engines.   Cross Ram setups were installed on both  Low decks and High decks in 1960 and 1961.   Cross rams WERE optional on Plymouth, Dodge and DeSoto 361 and 383 low deck engines in 1960,  and Dodge/Plymouth in 1961.   I had a set installed in a 1960 Polara back in the 80s but didn't have the exhaust manifold heat riser setups for them so it was  a bear getting the car warmed up and I eventually put the single four barrel back on and sold the rams to a 300 owner.   Those exhaust heat riser pieces are the very hardest to find of the entire setup.   So you will need the carbs,  the cross rams,  the cross-over piece, clamps,  block offs plates for the heads, bell crank type linkage,  exhaust manifold parts,  air cleaners...... in short expect to pay at least  $4000. US if you can find it all.      The fender wells also had special removable plates so you could get in to change the spark plugs from behind the front wheels,  as you can't change them from above with the cross rams installed.

 

In short,  I wouldn't do it if you want to enjoy the car a lot.   A dual in line four barrel progressive linkage setup would be much easier and cheaper to find and install, with a whole lot less parts to find and also gives better fuel economy than the x-ram setup.   The In line setups were used in 58, 59 and 62,  but you would have to find a correct dual four intake manifold that fits a low block engine as the manifold for the high block engine is wider.     I owned a 1962 Chrysler 300 with the inline dual setup for 26 years and it always ran great and fuel economy when driving normally was excellent.    This is the setup that was in my 300.

post-76810-0-87756400-1437411707_thumb.j

Edited by mopar380 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now