Recommended Posts

My 65s wiper switch fell apart when I took it out of the dash. I reassembled it and I did a continuity check and Im confused. I know the switch is the grounds for the system. But at least one of the two wiper lug is grounding all the time. I got a replacement switch from a Le Sabre. Its the same switch but the switch post is shorter. I figured I would use to do the continuity check and it performs the exact same way.

What is the normal switch operation, Clockwise (the way I picture) or Counterclockwise? Why would it allow to ground in each position? I guess its possible the new switch is bad too, but from what I could tell of the contacts when I assembled my old one, its designed this way. Is it grounded for the parking mechanism of the motor?

Edited by alini (see edit history)

Share this post


Link to post
Share on other sites

Hi Chris,

 

I realize your post is from a few years back, but my 65's wiper switch fell apart on me Monday when I was messing with the ignition switch connection. I can't find how it goes back together in the shop manual and am not figuring it out. I have two springs and a circular gold plate/bracket. Maybe there's another piece hiding in the dash compartment that I'm missing? Appreciate any guidance / insights you can share. 

 

You probably figured this out already, but the wiper switch turns Clockwise. I don't know the answer to your grounding question. Sorry. 

wiper switch connection.jpg

Share this post


Link to post
Share on other sites

As you surmised, you're missing the switch part that fastens to the dash.  Probaly wise to find a good one.  This happened to me once and i thought it fixed it at least five times before finding a replacement.

Share this post


Link to post
Share on other sites

 Chris sold his Riviera a while back and we haven't seen him on the forum for a while, so he may not see your

post.

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, RivNut said:

As you surmised, you're missing the switch part that fastens to the dash.  Probaly wise to find a good one.  This happened to me once and i thought it fixed it at least five times before finding a replacement.

Ed, unless I am misunderstanding you the exterior dash switch components are all there and still in place. These internal dash pieces came off during my ignition switch debacle and I am trying to reassemble. 

Share this post


Link to post
Share on other sites
2 minutes ago, DShoes said:

Ed, unless I am misunderstanding you the exterior dash switch components are all there and still in place. These internal dash pieces came off during my ignition switch debacle and I am trying to reassemble. 

I'm thinking that if you'll take the part out of the dash, you might be able to figure out how it goes back together.

Share this post


Link to post
Share on other sites

I took my switch apart, but dont recall everything    I do know the larger spring is what keeps the brass piece in contact with the switch (end with the wires) and the smaller spring is to reset the plunger for the washer button.  If I recall the brass plate sits with the drepssression against the switch side and would make contact when they were turned into position. 

 

Good luck, I know I had a hard time finding a replacement which was why I rebuilt mine

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, alini said:

I took my switch apart, but dont recall everything    I do know the larger spring is what keeps the brass piece in contact with the switch (end with the wires) and the smaller spring is to reset the plunger for the washer button.  If I recall the brass plate sits with the drepssression against the switch side and would make contact when they were turned into position. 

 

Good luck, I know I had a hard time finding a replacement which was why I rebuilt mine

 

Thanks Alini. You're confirming my thoughts. Good to know I'm not missing an additional piece. Hearing small parts become disconnected and bounce around inside the dash compartment is never good...

Share this post


Link to post
Share on other sites

Mine did the exact same thing. I assumed it was broken. I hoped I saved everything from it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now