Sign in to follow this  
Yohdda

1957 Buick Century Trunk Emblem

Recommended Posts

Hello, I am new to this forum. I have just acquired a 1957 Buick Century 4dr hardtop, and it is an amazing car. It was restored in 1990, and is in excellent shape. I have had to do only minor work on it (water pump "thanks Russ!!", torque ball leak, brakes, speedo, belts, etc.) What I am having issues with is the trunk emblem. The four knobs on the back of the emblem that hold it onto the trunk lid are broken off. I have contacted a couple of local body shops, and they say that they cannot weld those "knobs" back on.

So I am either looking to buy a "new/used" one or ideas on how to attach it to the trunk lid.

I have attached a photo of the emblem in question.

Thanks!

Jason

post-101346-143142571287_thumb.jpg

post-101346-143142571287_thumb.jpg

Share this post


Link to post
Share on other sites

Drill and tap where the "knobs" were and thread studs into those holes. Insert into car's body and use nuts to hold it in place. I've done it a number of times. It's a good idea to use a bit of epoxy on the studs since there are usually only a couple of threads able to be tapped into the emblem....................Bob

Share this post


Link to post
Share on other sites

Never thought of that! I am going to give that a try. And maybe even use a little two way automotive tape to eliminate any potential rattling.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this