Jump to content

Temperature gauge not working


Recommended Posts

The temp gauge on my 28' Studebaker Dictator doesn't seem to be working, as the needle does not move. Never changed any temp gauge, so would like to know how difficult or easy this might be. Looking for someone who has been down this road, and what you had to do. Thanks for any reply.

Link to post
Share on other sites

If you search 'king-seeley' on this site you should find something to help you. I've not been down this road myself yet but do need to at some time. I think there is someone out there specialises in repair of these.

Link to post
Share on other sites

QUOTE=nzcarnerd;1180517]If you search 'king-seeley' on this site you should find something to help you. I've not been down this road myself yet but do need to at some time. I think there is someone out there specialises in repair of these.::JOHN WOLF & CO.INC ::Willioghby, restoration of speedometer, tachometer, Automobiles ,Aircraft ,Boats ,Custom Instrumentation Gas Tank Sending Units, Mechanical Temperature Gauges

Link to post
Share on other sites

No guarantees, but you could try this. Take the temperature sender bulb out of the cylinder head - gently - and drill a very small hole in the end of it. Get a syringe and some ether. Inject a small amount of ether into the bulb. Seal the hole quickly with a small screw and/or solder, put the bulb back in the cylinder head and start the engine. Hopefully the guage will register. If you smell ether, there is a hole in the system somewhere.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...