Jump to content

96 Rivi Dash Lights out


501 Club
 Share

Recommended Posts

Hello,

The other day I went to the scrapyard to pick up a couple different things for my Riviera. I picked up a dashboard because my old one was cracked, and I also picked up a light for the passenger side interior door handle, which was out. I replaced the dash and light, then when I turned on the car and the automatic headlights(previously not working) were fixed, but all of the dash lights (cluster, temperature controls, passenger temp controls, etc.) were all out. The mileage display and gear range lights located on the dash are dimming as usual when the headlights turn on. I have checked the fuses under the rear seat, but other than that I do not know what else to check. Any recommendations would be greatly appreciated!

Link to comment
Share on other sites

I will bet the salvage yard cluster did not work. Swap your old one back in. If the original one works swap out what is cracked.

Went back and reread your post. You swapped out the dash pad not the cluster. Is the plug in the dash for the cluster making good contact. Maybe try some contact cleaner. On our units if it doesn't display, it usually is bad...

Edited by DAVES89 (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...