Jump to content

Voltage Regulator Installation 41' SSE


Guest Tim Romans
 Share

Recommended Posts

Guest Tim Romans

Hello everyone,

I just bought a new voltage regulator to put on my 41'. When I removed the old one, I did mark the wires with tape to put them back in the right spot, but when installing the new one, I noticed I had tape around two wires close together and I marked them ARM for the armature. I just wanted to make sure that both of them do in fact go in the ARM poston the regulator and if so, how? Do both terminals go on under the copper plate? One on top the plate and one under? Or, both under but on each side of the plate. Thanks again for all your help.

Tim

Link to comment
Share on other sites

Tim,

Yes, You should have two wires going to the "GEN" or "ARM" terminal on the regulator. If my book is correct, one should be Yellow w/ Green crosses going to the Starter Solenoid (this is how the solenoid relay grounds) & the other should be Yellow w/ Black Crosses going to the Generator "A" terminal. If you are referring to the U shaped washers, you should put both wires underneath of the washer. Hope this helps.

Jason

Advanced Electrical Rebuilders

www.aerrebuild.com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...