Sign in to follow this  
SeventhSon

Avanti Rescue

Recommended Posts

Yes, a little soap and water, amazing stuff. The things you learn on this site - I'll have to check out those old hubcaps. Thanks Paul.

Share this post


Link to post
Share on other sites

And here there are - I knew I had seen those caps somewhere before! Hmmm...should I paint my Avanti pink? Dale Earnhardt's first racecar was pink...

Just kidding (about painting the Avanti pink, not Earnhardt's race car, that was pink).

post-81474-143138934123_thumb.jpg

post-81474-143138934125_thumb.jpg

Share this post


Link to post
Share on other sites

Today is Monday, April 23. I went to see visit my girl in the "hospital" - things are coming along nicely. They hit it pretty hard last Monday afternoon and all day Tuesday, accomplishing a lot of the things on the list. They got the fuel line and filter fitted, rebuilt the distributor, installed new heater hoses, torqued the front end components, filled and bled the brake system (had a hell of a time with that, so I hear), replaced the transmission gear oil, replaced the universal joints, replaced the rear end gear oil, and replaced the shocks. I forgot to ask about the rear axle bearings, but I'm sure they probably got to it as well.

Most of the parts I ordered from Dave Tbow arrived today shortly before my visit. I stopped on my way and got a little over 7 gallons of gas, which I carried to the shop in 2 containers. Dumped that in the tank - first gas she's seen since December. I wanted to see if the gas gauge worked so we hooked up the battery and turned the key on. I was disappointed. Nothing showing on the gauge. I'm still hoping it's a fuse - my theory is that after the old sender unit got juice after all those years with nothing going on it decided to pop the fuse. That's what I hope - I expect I'll be going back by tomorrow and I'll suggest taking a look at that.

In the first picture you can see the parts that came today on the trunk lid, received a new parking brake cable, wiper blades, and condensers, still waiting on a rear axle nut and headlight switch. In the second picture you can see the fuel line and filter and make out that fan shroud repair I had to undertake, since I haven't found a replacement yet. In the third and fourth pictures you can make out the new shocks and see the cleaned up rear end cover they removed to change the oil. Oh, they also installed the new parking light lenses, amber and clear, with new seals, I'll have to get a picture of that tomorrow. I wasn't going to go in tomorrow but I think he's going to make an attempt at cranking her up - I don't want to miss that!

This afternoon I ordered a few more items, a battery hold down, a couple of "J" bolts for the battery hold down, and two chrome clamps for the supercharger hose. Oh, and we went ahead and ordered the correct size battery - I was going to wait, but what the heck, might as well get it done, eh? Maybe I can sell the other battery for 50 bucks - new, barely used. Now I've got to go search the garage for the axle nut washer - one is missing and I'm sure it was on there. I can't seem to find one to buy, so I gotta see if I temporarily misplaced the original one.

More tomorrow.....

post-81474-143138938565_thumb.jpg

post-81474-143138938579_thumb.jpg

post-81474-143138938592_thumb.jpg

post-81474-143138938607_thumb.jpg

Share this post


Link to post
Share on other sites

Good deal Chris, making progress! If you don't mind me asking, what shop is the car at?

You will be driving that Avanti before you know it!!!

Share this post


Link to post
Share on other sites

Chris, I can almost hear her now. Looking forward to seeing her on the road soon. Great job for getting her back to life.

Share this post


Link to post
Share on other sites

Chris, re your engine. You are missing a spring that goes on the back of your accelerator/bell crank rod. You can see it in the attached pic.

post-48480-143138938714_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks Paul and John - we're getting there! John, I was looking at that spring before (I have a couple of pictures of your engine I took when I was out there) and I couldn't figure out where yours terminates. There is a spring hook that goes under the rocker cover nut, and I'm thinking that is where it originally hooked. Anyhow, it was missing from mine when I got the car (along with a few other things), so I'll have to see if I can scare one up. I left the spring hook off because it was all rusty (huh, imagine that), so I'll have to stick that on I guess.

I talked to the owner of the shop this afternoon to get an update. They're making more progress, but are running into the usual time consuming delays, such as rusty nuts and bolts, corroded electrical fittings, etc. The brake cable replacement task took several hours due to the rust situation. And, of course this all adds to the cost - we had an in-depth discussion about that in our conversation. I wanted to make sure that they understood that there was a limit to the budget and when it hit a certain point then it was "done". Hopefully it will be running and drivable at that point. So I think we're on the same page there - it's a great shop with some very capable people and I would like nothing better than to turn the car over to them and say, "Have at it", but I'm just a working stiff like lots of people. So, I have to take it a little at a time - as it is I've stretched the budget beyond anything I ever imagined at the beginning.

So, among the items I mentioned yesterday, the shop installed the torque bar bushings, put a correct battery in her, installed the rear parking brake cable, re-packed the rear axle bearings, and had a new axle washer fabricated (can't get those anywhere, probably a hundred thousand of them sitting in an old building in South Bend somewhere). As I got off the phone tonight the shop owner said his mechanic was holding the timing light and motioning for him to fire it up so they could set the timing. Sounds like progress to me.

Share this post


Link to post
Share on other sites

Chris, I just love it when a plan comes together. Hopefully, your car will be running and driving tomorrow, and you can take her home on the weekend.

Yes, the spring terminates on the valve cover nut. It is not a heavy loaded spring either. I think that SI sells the correct pair.

And on money, who knew that I would be into a bit north of $30K when I started my refresh. I am still glad I did it. It has been very rewarding to bring my Avanti back to life and on the road again.

As always, keep us posted.

Share this post


Link to post
Share on other sites

John - I'll look into Studebaker International and see about those springs. Maybe they will have a new spring hook too, so I don't have to put the rusty one back on. I'll check it out.

Share this post


Link to post
Share on other sites

Nothing going on in Avantiland for a few days, while the shop owner and crew are indisposed. Hopefully Monday will be the day things come together - hopefully. The suspense is nerve wracking, let's get this thing together and drive it! Meanwhile, I ponder future work on the car. I think the next substantial things I tackle will be the front and rear glass rubber. The ones on the car are, of course, petrified - I can't hardly stand to look at them and I certainly won't let any water touch the windows. Not until I replace the rubber. I've worked on a couple of these before, once I helped a friend replace the seal on the windshield of his "56 Ford pickup and I replaced the windshield seal on my Volvo P1800E by myself. It went surprisingly well - not so sure how the Avanti will play out.

One thing that causes me some trepidation is the chrome (stainless?) trim that runs the length of each gasket, front and rear. I can never imagine getting that back on at all, let alone correctly. I've been reading about the seal replacement on Bob Johnstone's Studebaker website and deriving some encouragement from that. I expect I will tackle that sometime before the end of this year. Whew! Gives me indigestion just thinking about it - much earlier on in this thread someone (sorry, I can't place the name) recounted their ordeal with trying to get the windshield back in their Avanti, 3 days and much frustration, to the point he was wondering if the windshield even fit the car! Yikes! Hopefully that was one of the early models that had some "issues" with fit due to the fiberglass tooling.

Glass seal replacement - coming soon!

Share this post


Link to post
Share on other sites

Seventhson, did you like your Volvo p1800? How did it compare to your Studebaker Avanti? Do those cars suffer from any problems that should be looked at before buying? Thanks for any information that you can give me.

Share this post


Link to post
Share on other sites

Straight shooter, the P1800 I got had very low mileage, about 23,000. It was nice, but as with all Volvos it had its certain problems. This car had a problem with the idle setting and seemed underpowered - it was fuel injected and I'm sure that a setting was incorrect somewhere. When I got the car I could not get it to run consistently - when I picked it up I was able to drive it several miles, then it shut down. I tried all sorts of things to get that car to run - even replaced the onboard computer that resides under the front seat. Finally, I talked to a Volvo mechanic and he suggested the fuel pickup filter in the gas tank could be clogged. I thought, "That's not it"... and proceeded to fool around with other options for a couple of more weeks. In a fit of frustration I finally pulled the gas tank and cleaned it out. The fuel pickup screen was clogged! That's also when I found out the car's dirty little secret - it had been in a flood. Yep, I got taken. After I cleaned the fuel tank out the car started right up, every time. Ran pretty nice, but still had some idle and power issues. I did a bunch of work to it, fixed the rusted through sheet metal on the cowl, replaced the windshield seal (since I had it out for the cowl fix), blasted and painted the wheels, put a new grill in, etc. I blew a hole in the side of the transmission by flooring it and dumping the clutch. In reverse. A little, ahem, youthful exuberance on my part. All in all, a nice little sports car, if you can find one well taken care of and un-submerged in water. In the end I got tired of the difficulty in finding parts and the expense of them and I sold it.

Do I like the Avanti better. Way better. Bigger engine, loads more power, more historical, American made. What's not to like?

Share this post


Link to post
Share on other sites

More on Volvos - hopefully not too boring. I've had 5 Volvos in my life, the first when I was 15 years old, and in anticipation of my driver's license. My brother Don had a '65 Volvo, the basic 4 door sedan. That car would run until it warmed up (3 minutes, max) and then quit. I believe Don had had enough of it and said, "Here, you can have it, see if you can get it to run." So, I had my first car, free of charge. Just get it to run. It ran great for 2 minutes or so, then complete shut down (maybe it had a clogged fuel pickup!). Despite fooling around with it (and not really knowing what I was doing) we never could get that car to run. I finally traded it to my brother Dennis for a '63 Chevy II station wagon (that he got from brother Steve, see a pattern here?) that needed a motor. I went to a salvage yard and bought a 235 cubic inch 6 cylinder motor and put it in the station wagon. Dennis finally found another Volvo (for free!) and put the motor from it in the '65 Volvo. Drove it for quite a while until, one day, he was trying to navigate a snowy hill and the car slid off the road, down a ravine and into a tree. Curtains for that car, and luckily no injuries to Dennis (boy, he was mad though).

Share this post


Link to post
Share on other sites

Next Volvo was a 1968 2 door sedan I bought from my brother Kevin (keep 'em in the family). Nice looking car in good shape. Again, a problem with the dual Stromberg carbs that I believe was somehow affecting the brakes. The car ran sufficiently for the first few months I had it. Then, on a trip returning from North Carolina with my girlfriend I was stuck in bumper to bumper traffic on the Beltway when I noticed it felt like the car was dragging a battleship anchor. Or maybe the whole battleship! The brakes were locking up on the front - I was able to drag it to my girlfriend's parent's house. The front rotors were smoking - I rebuilt the calipers and I believe replaced the rotors. All this was done on a shoestring, always poor in those days. The brakes were still not right, I think it had something to do with the vacuum booster unit, you basically had to stand on the brakes to stop and the engine just didn't have throttle response.

One day I bumped into a family friend and he was taken with the car. He wanted to buy it! I told him about the problems and told him I wouldn't do that to him. He said he could deal with the repairs and kept offering me more and more money for it. Finally I told him, "OK, it's yours!". I ran into him a couple of years later and he told me he had nothing but trouble from that car. Always working on it. I warned him!

Share this post


Link to post
Share on other sites

My next 2 Volvos were the best ones. I had a green '69 4 door sedan that I got from, you guessed it, my brother Dennis. That car ran and ran - always started, always reliable. And, contrary to some people's belief that Volvos are bad in the snow, I could never get that car stuck. I would try to get stuck in snow banks and I was always able to rock it back and forth and she would chug out of it. I did have an issue with the steering on the car for a while - the steering wheel developed a "wobble" in it one day and it got progressively worse over time. I tried all sorts of things to remedy that situation. I thought I had a bent wheel, I checked the tie rod ends, the steering arm, the steering box, I even got a new steering column from a salvage yard and put it in. It helped a tiny bit.

So, here I would go, driving down the road with the steering wheel wobbling back and forth. Not a huge wobble of a foot side to side, but noticeable. My girlfriend would laugh about it and say, "Why don't you fix that!?" "Because I can't figure out what it is!" This went on for months, it seemed. Then one night, as I was cruising around with my girlfriend, I got a flat tire. I pulled over and changed the tire, got back in the car and resumed driving. After a while my girlfriend exclaimed, "Hey look!" "What?" "The steering wheel is not wobbling anymore!" "Well, so it isn't," I said. I was so used to the wobble I didn't even notice when it was gone. So, it was the tire. I examined it the next day in the light - it had a hole worn all the way through the tread and belts. I took it to a friend who was in the tire business. He said it was a separated belt. "How long did you drive it like that?" he asked. "Dunno, maybe 5,000 miles." "Ha, I wouldn't be able to drive a tire with a separated belt for 5 miles, let alone 5,000!"

The only other problem I ever had happened one day out of the blue. As I was rolling through a parking lot suddenly I heard a ping, screech! Coming from the engine compartment, screech, screech. I thought I had a main bearing go. I limped home with it and pulled the motor. At the rear of the motor I saw the problem and breathed a sigh of relief. It was the transmission input shaft pilot bearing that scattered, leaving just the bearing race in the flywheel. At least it wasn't a crank or rod bearing!

As I was crouched beside the engine, clawing at the bearing race with whatever I had handy trying to pry it out of the flywheel, my father approached. "You want an easy way to get that out?" "Well, yeah." "Take some wheel bearing grease and fill up the cavity, then find a pin or shaft that fits sort of snug in the bearing race. Stick it in the race and give it a smack with a hammer." I looked at him like he was crazy. "That's not gonna work!" "Try it." So I did. The bearing race popped right out. The look on my face must have been priceless, because my father got a good laugh out of it.

As I always say, experience, it's priceless.

Share this post


Link to post
Share on other sites

Well, back to Avanti World today, I'm happy to say. I eagerly took a trip to the shop today to visit my baby and see how things were coming along. I was happy to get to see the car again, even though every time I look her over I wish I could "pretty her up" some. So much damage over the years from just sitting. But, it gives me something to look forward to, gradually fixing her up and making her presentable. She'll never be a trailer queen or show winner, but if I can bring the car back to some semblance of her former glory I will be content.

The work continued, even as I hung around the shop for over an hour. I was so grateful to the shop guys for letting me just hang around and talk and basically get in their way. It was really nice to see things coming together. The rear torque bar bushings are replaced, the rear parking brake cable is replaced, they bled the brakes again while I was there and installed the new headlight switch. The headlights now work, the parking lights work, the signal lights work, and we even got the brake lights to work. The gauge lights are working (cool red lights!) and they even said they got some movement out of the gas gauge. So, we're moving in the right direction.

When I was inching out the door to head back to work (I didn't want to leave) I mentioned something about really wanting to hear her run. The shop guys hopped in and in less than a minute she was running. It was brief, but oh so nice. She sounds soooo good!

P.S. I got a video of the start up and I will post it as soon as I can get it online! I also have some pictures, but I seem to be having trouble uploading them here. I may post them along with the video.

Share this post


Link to post
Share on other sites

Pat, it's a great feeling to get to that point, I gotta say. It's what keeps us going, eh?

Share this post


Link to post
Share on other sites

Chris, give us a status on what the shop has left to do, and when you expect to be able to drive her home. Sound like things are progressing at a pretty good clip. Her homecoming cannot be too far away now.

Share this post


Link to post
Share on other sites

John, they are supposed to do the alignment this morning and take her out for an initial shake down. Maybe even try to get her inspected. If all goes well I hope to bring her down the road later today - I'm keeping my fingers crossed! Let's see if I can post the link to the video of the start up yesterday:

Flickr: AvantiChris7's Photostream

Share this post


Link to post
Share on other sites

Oh, sooooooo sweet. Let us know how the drive goes too. We are all getting excited for you. It will be great to see her running down the road again.

Share this post


Link to post
Share on other sites

Thanks John - it is exciting to get to this point and realize she can make it out on the road again. After all these years....

Share this post


Link to post
Share on other sites

Yep, "rocktown", the nets are really cool. Speaking of really cool, I picked up the car! We went to the shop at 1 o'clock today and she was outside, ready to go! I spoke with the shop owner for a few minutes about the car, he said he drove it about 10 miles and was very impressed with how she ran. The only concern he had was it seemed to be running hot. He told me to keep an eye on that. So, I went outside, jumped in and turned the key. She fired right up. I mean, right up. I backed her up, put it in first and away I went, with my wife following for backup. I stopped about a mile up the road and put about 10 gallons of gas in her. The gauge came up to a little past half full. Nice! Then it was a nice ride through the typical Northern Virginia traffic for about 20 miles.

The temp gauge stayed up around 210 degrees most of the time, and at one point it pegged all the way right! I pulled into a local park and opened the hood, expecting the worst. Everything looked good, no boiling over, no hissing or spraying, none of the usual things would expect when a car is overheating. I got back in, turned the key and she fired right up. Down the road I continued, and after about 3 more miles the temp dropped to around 190 and stayed there the rest of the trip. So, I was breathing a little easier. It might be the sender unit or the gauge, another thing to tinker with.

I have to tell you, I love this car. All the blood, sweat and tears were worth it. It is such a cool car to drive, it sounds so bad (that's good bad, not bad bad), it's so quick. It's just cool all around. Now I know what folks like John Feser, my brother Brian, Nimesh Solanki, and several others were talking about when they said it would be worth it. It was and is.

Last week Paul asked the name of the shop I took it to and I held off saying anything, mostly so I could see how things played out and get a feel for how this was going to come together. Now that I know I can say with pride that the shop is Craftsman Automotive in Falls Church, Virginia, run by Alan Himes, a longtime Avanti guy. A mechanic named Dan (a Jaguar mechanic!) did most of the actual hands-on work on my Avanti and I would not hesitate to let him and Alan have the car at any time to work on it again. The other mechanic, Rob (another Jag guy!) also helped out some on the Avanti. I am very happy with the quality of work they performed, they followed the list I gave them, told me about some other things they found that needed attention, and got the car exactly where I wanted it to be. My hat is off to them. I'll be posting more pictures from today, but for now here is another video, this one showing how nicely she idles:

Flickr: AvantiChris7's Photostream

Share this post


Link to post
Share on other sites

I guess you will be out cruising now and not on the PC!!! Good For You. Have fun and enjoy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this