Sign in to follow this  
Earl Filippelli

1988 Reatta cruise problem

Recommended Posts

Hello All. Drove my car today after a 3week set up.the car runs great but after 3years I get message cruise disengaged , but the cruise works fine. Any ideas? Thanks in advance , Earl.

Share this post


Link to post
Share on other sites

I have an '89 Riv, but come here because this forum is one of the best on the internet for automotive stuff. Last fall I had trouble with my Cruise Control after I had restored it a year previous. I replaced the Servo and did quite a bit of other things but it still didn't work. I then went to Florida for 6 months, when I got back and put the Riv on the road, the cruise was working fine!!!! When I drove a Cab in Boston for a living I spent some time working out of a garage which had about 25 to 50 cars on the road. There was one mechanic who was considered a guru. He was very humble and unassuming. Once I was in the garage waiting for my cab. I watched them trying to fix an engine. He wandered over and watched for a while. Then he stepped up, put his hand in the engine compartment, shook something for a few seconds and the engine started up.

Edited by SwiftBuicks (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this