Jump to content

Pulled it out of the garage.


Guest Doc_Reatta

Recommended Posts

Guest Doc_Reatta

FINALLY, getting back to restoring my 1988 RED/CAMEL baby. New poster here but been reading the posts for awhile now. You guys are great!. Had the transamission rebuilt, new fuel pump and tires. Currently, needs some electrical work (no IPC lights aka ye' ole shorty issue). Turn the key to on and interior lights flicker and relays crackle). Eliminated all fuses and relays, now heading towards the BCM. I have an 89 also parked for "spare parts" so that will be my next trick to try to fix the electrical problem. A little history on the car: I bought my baby back in 1999 from a lady who worked at the GM Proving Grounds here in AZ. She had always wanted a Vette but after seeing the Reatta on the grounds, she bought it right then and there. Very low mileage and garaged at all times. Sweet. :cool:

Link to comment
Share on other sites

Guest Doc_Reatta

Not yet. Was going to do a quick swap of the BCM first (quicker and MUCH less work involved). BUT, that will be my next step if the BCM turns out not to be the problem. THanks for the advise! It is appreicated!

Link to comment
Share on other sites

Guest Doc_Reatta

So sorry!!!! Forgot to mention also that the CRT only shows "radio". Can't acess other features on it (CRT). Read somewhere in another post a similiar issue where the BCM was at fault.

Link to comment
Share on other sites

It sounds like Retained Accessory Power which allows the radio to stay on after the key is off. Does it quit if you open the door ? If so odds are a bad or maladjusted start switch on the base of the steering column.

Link to comment
Share on other sites

Guest Doc_Reatta

You may just be right about the start switch. Difficult trying to get it to "accessories" position. Let me drop the column and recheck. I'll keep you all posted. Thanks to everyone for their assistance! Doc.

Link to comment
Share on other sites

  • 2 weeks later...
Guest Doc_Reatta

Well, after much troubleshooting, it was the BCM after all. I pulled the one out of my 89 and replaced it and sure enough, everything came back normal. One question though....Do I replace both eproms or just one (and which one)?

Link to comment
Share on other sites

Guest Doc_Reatta

Think I answered my own question. Got, un-lazy and searched the forum and found that the smaller chip contains the vin, od reading, etc. Gonna replaced just the one since the replacement BCM came out of an 89 and mine is an 88.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...