Jump to content

1976 Thermal Valve(?) question for Heater


24seven
 Share

Recommended Posts

Howdy All,

I have a 1976 Riv(455)S/R and my question is about the heater. I replaced the core and hoses. The vent works well and blows hot and on "High". When I go to use the heater, it only blows low speed. The vent works in all ranges as does the AC. I replaced the resistor as well; no change.

I have a manual and it mentions some kind of "switch" at the back of the Passenger side head. Does anyone have a part number or source for this and/or name? It appears to screw into the block and has two electrical prongs on it. Will coolant leak out if I remove it, to show the parts guy?

RockAuto, Napa, Autozone have all said they don't stock it.

Thanks for any/all replies,

HenryJ ROA 11572 SoCal

Link to comment
Share on other sites

Yes Rob!

Thanks so much. That is the part except that the

one on my car has two prongs like a houseplug.

I figured I might have to do the Ebay thing.

Do you think I would be able to adapt this somehow,

or should I just wait and hope another correct one shows

up?

Thanks Again, HenryJ ROA 11572 SoCal

Link to comment
Share on other sites

Henry,

When I go to use the heater, it only blows low speed.

I think you are confusing the low speed blower relay with the temperature control switch.

The temperature control switch that screws into the right rear of the head is designed to allow the current to flow to the blower motor after the temperature reaches a certain temperature. This switch has nothing to do with the blower speeds.

There is a blower relay switch that is mounted on the firewall that controls your blower speeds. If your system is only working on the low speed, I would zero in on the blower relay switch. I've had to replace that switch many times over the years on my 71.

Bob Bonto ROA # 277

Technical Advisor 71-73

Link to comment
Share on other sites

Bob and Rob,

Thanks very much for the direction and manual scan. I see now which relay you speak of on the firewall. I will replace it and keep you posted. Thank you both, very much for the Info. I'll replace it and check back.

Thanks Again, HenryJ ROA 11572 SoCal

Link to comment
Share on other sites

  • 1 month later...

Well Folks,

It's been a while and I finally replaced the Blower Relay

as suggested, with no change. looking at the scan provided,

guess I'll do some back tracking. Again, all other Temp control ranges work. The A/C and Vent will respond to the toggle/slider arm to decrease and increase Blower speed. It's just the Heater function which only stays on the low setting and does not respond to Toggle/Slider arm movement.

Thanks for all the help again. HenryJ ROA 11572 SoCal

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...