Jump to content

engine has an electricial problem question


Recommended Posts

Acquired my first Reatta (1989 w/90K) this week & have some questions. I have read numerous forum pages to get familar with these cars but I have the EO41 code & the engine has an electricial problem notification which seems to be a common problem with Reatta's from what I have read. Both of these problems were fixed by the Dealer I purchased car from but have resurfaced. I talked with the mechanic that did the repairs & was told that the cam sensor was replaced & that the crankshaft wire was bad which was replaced. I also replaced the cam sensor before speaking with the mechanic. My ? is could a bad ignition switch cause this same problem as the touch screen goes blank on occasion but have notice if I move the ign switch it comes back on. I have restored/rebuilt & been a gearhead most of my life but cars with computers are still new to me. Car was a one owner, garage kept until sitting on his lot for almost a year, and is in very very good condition.

Link to post
Share on other sites

It could be as simple as something as a bad connection. yesterday I changed my radio in my 90 conv and had to takeout the temperature control unit,and did not reconnect the unit while testing the new radio. the electric problem light came on. then I shut off car and reconnected temp unit and the light went away.

Link to post
Share on other sites

Sounds like the ignition switch on the base of the steering column is dirty or maladjusted. Has a slotted mount. Common inexpensive part so would just replace.

Link to post
Share on other sites

Thanks Ronnie. Still am wanting to know if the wire for the cam sensor is broke would you still get the EO41 code & the engine has an electrical problem notification. Will be checking the magnet in the next couple of days and will report back as to findings.

Link to post
Share on other sites

Do you have a broken wire? If you do repair it and see if the code E041 goes away.

If you are just throwing out a what if question that is the type of questions you use a FSM (Field Service Manual) for. Download the free version at Reatta.net and use it. You will be amazed at the what if answers you can find there.

Link to post
Share on other sites

I don't know. So far replaced the cam sensor. Was just wondering if this has happened to anyone else as I have noticed reading the forums that a lot of EO41 codes and engine has an electricial problem notifications seem to go together but no verification that both were corrected by just fixing the EO41 code. Thanks for the advice on the FSM. I will download it. grin.gif

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...