Jump to content

Help starting 64 Wildcat 2 door hardtop with dual quads, 4speed


Rik26675
 Share

Recommended Posts

Hello everyone. I have a 64 Buick Wildcat (I have posted about it on the general forum). We are looking to sell the car so this weekend I tried to start it. The vehicle had not been started by me for about a year, unfortunately it just was not a priority (big mistake). The engine (425 nailhead) has been rebuilt about three years ago. I put in a new battery, replaced the fuel filter and cleaned out the carbs. Then tried to start it. It turned over then nothing, no lights radio or other power in the vehicle. Is there a fuse or other place I can look/ replace to get going. Until today when the key was turned I at least got lights on the dash etc. Would appreciate any hints on starting this car. link to some more pics Kristi's Page

Link to comment
Share on other sites

Second vote, bad battery, or connection. I would head toward checking that battery first. Reason being if ya had nothing, then let the car sit and got something, the battery had a chance to "recover" slightly. Connections, depending on the weather can change, but mostly are not as severe as full power to nothing.

Link to comment
Share on other sites

Thanks for the help, The cables are new as was the battery but I may have gotten a bad one. It just cranked slowly at first so I put it on the charger.

The charger may be bad as it was showing 0 amps. Guess it will be back to Costco for another battery this Saturday.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...