Jump to content

88 crt and instrument panel


Guest
 Share

Recommended Posts

When my 88 coupe sets in the sun and gets hot inside, shortly after getting underway the instrument panel will go blank and all the telltales come on. Occasionaly after that happens everything will go out including the computer screen. Any suggestions on cause and fixes? I suspect a slight crack in a printed circuit as I had a similar problem with the digital speedometer in an 88 Regal that turned out to be a circuit board crack. Which, by the way, the dealer srvice techs didn't find. I got frustrated with them and tore it apart myself and found it. Are there any tech or service bulletins on this problem. My dealer has not been able to isolate or fix the problem. confused.gif" border="0

Link to comment
Share on other sites

Guest kennyw

I would suspect 2 different problems. One being the crt itself. The first one is probably what you say. A crack in a circuit board. I had my touch screen doing the same thing. Unbolted it, pulled it forward, and moved the wires. Still it would only come on if you hit it. I changed to another unit and now that problem is fixed. Figure that your crt problem is the same. Other crt post seen to end up with the same conclusion.....ken

Link to comment
Share on other sites

Guest kennyw

from search,,,,,,,,<P>--------------------------------------------------------------------------------<BR>I've had the same fault with my '88 Reatta (twice!!!). It's a real drag when it happens while driving; can't see how fast you're going, how much gas you've got, and the defrost goes into turbo-heat-mode(possible safety feature?). <BR>The last time it happened I repaired it myself. I forget the name of the module, it might be the BCM. It's the one fairly deep under the driver's side dash, accessible if you are on your back with the brake pedal in your ear. The problem was cold solder on an IC chip on the ciruitboard of that module, and I found several. <BR>My only other option was to purchase another circuitboard, which is a few hundred dollars expensive.<BR>My dash has not blinked or gone dead since.<BR>-Rich D. in CA

Link to comment
Share on other sites

I had a similar problem with my 1989. Only my IPC would go Blank in the winter when I had the defroster blasting and Max Heat! <P>I pulled out the instrument panel checked for good connections and reinstalled. I found no electrical connection problems. This Black OUT happened 3 or 4 times after reassembly - <P>It dawned on me that it only happened when the heat was High and on defrost. Now I just run the heat and defroster at a lower temperature. I have had NO repeat Black-OUTS since.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...