Jump to content

Oil Leak 56 292


Recommended Posts

Help !!! I have a new rebuilt 292 Y block . 1956 I had it running a couple days . Then one morning when it cranked it blew ot the gasket under the oil filter plate (spin on filter). I tried new gasket,double gasket,thick gasket, all with same results. ordered new plate & bolt same results . We used the old oil filter because we did not want oil pressure to high . It was at 30 lbs but I can not get gasket to stay long enough to test oil pressure. Has any one delt with this problem before ? Any sugestions ?

Link to comment
Share on other sites

  • 2 weeks later...

Well I ordered new plate & gasket New Pump New filter . Still same results. I tried glueing gasket also tried without glueing gasket . Same results!!!

I am now trying to find an orignal canister set up for the filter system. I need bolt, canister,gaskets,adaptors Everything to go to bare block. Can anyone help ???

Link to comment
Share on other sites

  • 1 month later...

This sounds like your oil pressure relief plunger is stuck in your oil pump, causing very high pressure (over 60-psi).

This is a sleeve that slides freely inside a bore, with a spring pushing against it. That's how it regulates oil pressure.

Normal oil pressure should never cause filter gasket problems. Hope this helps. - Dave

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...