Jump to content

89 Radio does not work


Guest
 Share

Recommended Posts

My 89 radio quit, no sound, no search or seek. I suspected the fuse in the fuse box since the problem started after I had to jump start the car. The fuse was fine. Does anyone have a clue what the problem might be? Is there another in-line fuse or is the radio shot? How easy is it to get to the radio?

Link to comment
Share on other sites

No, the cassette doesn't work (or eject). After inspection (I thought I was getting all the screens) I discovered that the GR EQ and BAL soft keys are now gone and have been REPLACED with a "TONE" soft key. I have never seen this soft key before. When touched, a combined screen showing the original balance screen combined with a new treble and bass slide bar. The screen appears to work (the balance bar moves and tone bars move) but again no sound at all. The TUNE soft key screen appears to be the same and appears when touched. All other soft keys appear to funtion (AM/FM and MEMORY). Thank you for your inquiry.

Link to comment
Share on other sites

I am not sure what is the problem as I am not very familiar with how the radio system works but I have 14 Reatta parts cars and do have a good radio for your '89 if it turns out yours is defective. The radio isn't one of the easier parts to get at but is accessable with a little work. It is located under the console directly below the ashtray. I can be reached at jfinn@computerpro.com for Reatta parts.

Link to comment
Share on other sites

The TONE control is associated with a radio that was available in the Riviera but not the Reatta. It sounds like your radio module (in the console has either lost its mind or is very confused. Could be just a bad data line but those failures are usually all or none.

Link to comment
Share on other sites

Is the radio module easy and cheap to replace? I had the car at the Buick dealer for an inspection and brakes and asked them to look at the problem while it was in. They gave it back to me and told me they couldn't help me with the radio. Is it possible they took a quick stab at correcting the no sound, no tuning problem by sticking in a Riviera radio module (and then giving up)?<P>kenneth.frank@gecapital.com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...