Sign in to follow this  
steveskyhawk

Advice Needed Please!!!

Recommended Posts

Hi all,

My new to me 91 Reatta coupe sure has a personality all it's own. When it has not been run that day it will start and stop. On the second try it will start and continue every time and run smooth. Should I mess with it or accept this quirk? Also the car seems to like to be run. After it has run for 5 minutes under a load the idle improoves and is perfectly smooth. It seems to me that it is running a little on the lean side when cold. That is the extent of my knowlege. Is there a fix or is this just a quirk?

As everyone recommends I had what I think is a pretty good shop do all the TLC stuff. Change brake fluid, coolant, motor oil, power steering, transmission service and tune up. I talked to the mechanic after the work was done and asked him if he noticed anything unusual or anthing he believed needed attention. He said overall everything looked great. I specifically asked about the transmission and he said it needed the service it got and the pan had a normal amount of clutch material. He added that he found a small piece of brass in the trans pan and believed it to be part of a thrust washer. Should I be concerned? This car drives like a dream.

I suggested that he replace the thermostat with a 180 degree and he insisted the the 195 was the way to go. I live in Southern California and it is hot sometimes. The temp guage almost reaches red line on hot days with the air on in traffic. Should I insist on a 180 degree stat? Haven't driven it since coolant change.

steve

Share this post


Link to post
Share on other sites

Welcome and hope you find this forum helpful.

First the thermostat, Yes you should have insisted on the 180'. They have tendancy to run hot when it's hot out.

The only other thig you could do, is pull out your ECM and send the chip out to have the fans reset to come on a a lower temp.

As far as the idle is concerned you will have to remove the

IAC (Idle Air Control) that is on the throttle body and clean it. I would also recomend that you run a can of "Seafoam" thru the vacuum system and another thru the fuel system. That should correct you running and idle problems.

For more information on your Reatta, go to Reatta.net and sign up. Then you will have access to the shop manual online.

Share this post


Link to post
Share on other sites

Be sure your fans are working. I was running hot in traffic and discovered my pusher fan wasn't working - motor had burned out. Replaced it with a unit fron Autozone ( around $25.00 ) and all has been well........

Share this post


Link to post
Share on other sites

Next time you do a cold start...turn on the key and wait 15 seconds before hitting START. You might have a problem with the fuel leaking down overnight and causing the stalling.

If that doesn't make a difference, you can scratch fuel off the list.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this