Search the Community

Showing results for tags 'hydramatic'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Basics
    • Forum Basics
    • Forum Support
  • AACA GENERAL DISCUSSION
    • General Discussion
    • Meets and Tours
    • Cars For Sale
    • Cars Wanted
    • Parts For Sale
    • Parts Wanted
    • AACA Library
    • Photo and Video Forums
    • Our Cars & Restoration Projects
    • Technical
    • Garages, Trailers and Towing
    • Judging
    • Legislation
    • Junkyards
    • Memorabilia, Toys, Art, Clothing and Printed Material
    • Newsletter Editors and Webmasters
    • Commercial Advertisements
    • Speedsters
  • BUICK PRODUCTS
    • Buick - General
    • Buick - Introduce Yourself
    • Buick - Meets & Tours
    • Me and My Buick
    • Buick - Garages and Memorabilia
    • Buick - Photos and Videos
    • Buick - Buy/Sell
    • Buick - Pre War - Technical
    • Buick - Post War - Technical
    • Buick - Modified
    • Buick - Performance Group
    • Buick Reatta
    • Buick Riviera - Riviera Owners Association
    • Opel
    • BCA Directors Only
  • OLDSMOBILE PRODUCTS
    • Oldsmobile - General
    • Oldsmobile - Technical
    • Oldsmobile - Buy/Sell
    • Oldsmobile - 1897-1966
  • CHRYSLER PRODUCTS
    • Chrysler Products - General
    • Chrysler Products - Buy/Sell
    • Chrysler & DeSoto Airflow
    • Chrysler's TC by Maserati
    • Desoto
    • Dodge & Dodge Brothers
    • Dodge Trucks
    • Plymouth
  • FORD PRODUCTS
    • Ford Model T (and older)
    • Ford Model A
    • Ford and Mercury - 1932 to 1953
    • Ford, Edsel & Mercury - 1954 and Newer
    • Edsel
    • Ford Thunderbird
    • Lincoln & Zephyr
  • CLASSIC CAR CLUB OF AMERICA
    • CCCA - General
    • CCCA - Buy/Sell
    • CCCA - Tech Questions
  • GENERAL MOTORS PRODUCTS
    • Buick Forums
    • Cadillac & LaSalle
    • Chevrolet
    • Chevrolet & GMC Trucks
    • Oldsmobile Forums
    • Pontiac & Oakland
    • Pontiac Flathead Owners
  • DOMESTIC MAKES & MODELS PRODUCTS
  • OTHER VEHICLES
  • INTERNATIONAL MAKES & MODELS PRODUCTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


Yahoo


Skype


Location:


Interests:


Biography

Found 4 results

  1. Hello all, Several months back I picked up a 54' Lincoln Capri from my uncle. I was somewhat distressed when we got it running that the car will not go in reverse or shift between gears in drive. After trying several adjusments, all to no avail, I am trying to find a shop somewhere in the Pacific Nothwest (Seattle/Portland area) that can rebuild a 54' hydramatic. I found a few shops that said they can do it in California, Texas, and the east coast, but I really would like to avoid shipping that monster across the country. Thanks Adam
  2. Where do I connect the pressure gauge to this tranny. I am looking at the original service manual, but it does not indicate the location. This is in my '62 Olds F-85. I know that there is some pressure but not to specs. Thanks again.
  3. I'm having problems with my 64 Bonneville's Super Hydra-matic 315 Dual Coupling Jetaway Transmission. It is "burping" about a half cup of fluid out of the dip stick tube each time put it in park and turn off the motor.:eek: I have put in new fluid, and checked it in neutral after driving in all gears, to ensure the fluid is at the proper level. Does anyone know exactly how much fluid this transmission holds, and/or have any ideas what could be wrong?:confused:
  4. Hi, new to this forum. I'm getting ready to tear down / partially disassemble my hydramatic and am in search of any other thoughts on my issue before I do. This started last fall and I have yet to resolve it. I posted this in the classic olds forum last fall and received some much appreciated feedback. Just looking for any other hydramatic tips or suggestions before I disassemble this thing. 1951 Olds hydramatic: driven out of drive way down the street and back first time in years. ( 10+ ?) Shifted late and hard. (nothing new) Pulled back into drive to drop the pan drain torus and clean screen, clean valve body... before I do I back up once and it sticks in reverse and will not let go. Reverse only... forward gears engage but will not move forward, bogs down as if under load (resisting reverse cone clutch is my guess) In neutral reving up, car inches forward a bit. No pushing the car forward in neutral unless cranking or idling. I've since drained pan, torus and cleaned screen, valve body (several times) checked linkage, checked the movement of the servos with air... I'm about to pull the tail shaft to remove the reverse clutch assembly. Any other thoughts? Much appreciated.