Killawattz

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Killawattz

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for the info guys, I've been driving it and I don't hear the compressor kicking on enough for me to be concerned. I'm not attempting to switch to air bags. At least to me, the rear struts are almost like air bags, without air they don't work, the back just hangs. Rides like a dream now.
  2. Hello everyone, I recently replaced the heater core in my 93 Riviera, which was quite the ordeal. After I was done, I was trying to figure out also why none of the lighters worked in the car. The front lighter had some nasty food residue in it, cleaned that out, still nothing. Checked fuses and sure enough the 20 amp fuse for the cigar lighter (wait...20 amps for a lighter?) was blown. Replaced it, and all of a sudden the air compressor kicks on for the rear suspension and scared the absolute shit out of me. The air suspension has never worked since I bought the car...til I replaced that fuse. Now I bought the car in late April of last year, and have put about 15k miles on it, all with no air in the rear struts. I'm worried they may have been damaged due to that abuse. So I guess what I'm asking is, is there any way to tell if the struts are still good? How often should the compressor be turning off/on? I'd rather not burn out the compressor if the struts are bad. The compressor runs for maybe 5 seconds once every 20-30 minutes, the rear of the car then raises up, and I can jump up and down on the back of the car and it holds air pressure. I took it for a quick spin around the block and didn't notice the compressor turning on.
  3. Greetings, I'm in the process of replacing the heater core for a 93 Buick Riviera, however in the process of removing the dash I have to remove the HVAC controls. I'm having a problem with this as I cannot for the life of me disconnect the HVAC controls. I'm seriously hung up on one electrical connector. What connector is this and how do I disconnect it? Any help is greatly appreciated, as everything has been going fine except for this part, and I'm afraid to try any more as the plug is getting chewed up.
  4. I see, so the remote start key fob is possible to acquire. Thank you all so much for the help, I know this generation of Riviera doesn't have a huge following, considering they aren't the best looking cars in the world and their sales at the time were horrible. But it seems like a really good car, and I know the 3800 II engine is a work horse. Probably the best V6 GM has ever produced. I expect the transmission to go out long before the engine does. I'm a mechanic myself, just haven't worked on anything of this era in a long time. I'll have to see where the other mounts are, perhaps just take them off and rebuild them myself with polyurethane. However, it's MUCH better after replacing that driver side ring mount, can't feel the engine shift at all anymore from a stop. I believe the struts could also do with replacing. It's a good car that has had regular services, but I think for the most part it was just left sitting in a garage, besides oil changes and brake pads, not much was done to it. So, on to the exhaust leak. I'm hoping when I actually get under it, something obvious shows itself. Again thank you all for the assistance.
  5. Greetings, I just picked up this beauty a few weeks ago. It only has 111k miles on it, and with the exception of a few minor issues, everything works. It's the SE package with the electric trunk and what not. I feel like I'm driving around a couch. Everything on it is incredibly clean, even the engine bay is clean enough to eat off of, no leaks at all. Best 2k I've ever spent on a car. It looks like it spent most of it's life garaged, and will continue to do so. And on to the broken things: For some reason, the heat does not work. The radiator is full, it does not over heat, and the AC works great. It is summer in AZ, so not a huge issue right now, but at some point it needs to be fixed. Preferably before next winter. The front mount shackle towards the the front right of the car was toast, so I replaced it, but it seems impossible to find any of the other mounts. Can anyone shed some light on this? I've heard that not too many of these cars were produced, so the aftermarket never built the mounts for these cars. And finally it has an exhaust leak. It comes through the vents when the car is stationary, goes away once the vehicle starts moving. I didn't see anything obvious when I looked from the top, but I'll have to get under it and stuff a rag in the exhaust to try and find the leak. Are there any common culprits? Also, according to the build sheet, this car came with remote entry, but I have no remote for it. Could Buick get me a remote if the car has the capability for key-less entry? Finally, while some like the landau top, I don't. But at first glance, to make it look like a non landau top car, it would appear some body work would need to be done? I see little posts the vinyl top clips on to, so I think it's more than just remove landau top and be done with it. Has anyone ever tried this? Thanks