Jump to content

Newbuickguy

Members
  • Content Count

    7
  • Joined

  • Last visited

Everything posted by Newbuickguy

  1. I attend that show most years. Excellent weekend in Columbus. Good Guys Custom Show (6000 cars) is the same weekend. The picture is too dark. The interior has white seats. No rips or separations- but missing a few buttons on the seat backs. Thanks for your comment. (My brother has a light green 66 Chevelle with fawn interior and it always gets attention at shows.)
  2. Problem solved! My friend Steve figured it out. It was the condenser inside the distributor cap that was pulling juice making it send a weak spark to the plugs. Started up on the first turn. Thanks for all the time taken to respond to my question. Can't wait to get that top down and go. (I'm beginning to like this car again.) The fuel pump is the original one so I'm thinking that may need replaced before I take it for a long haul. Any other suggestions to make it more dependable are welcome.
  3. Very helpful. These are ideas we have overlooked. We'll try these and give you an update. Thanks for taking the time to respond.
  4. My name is Max and I really need some help diagnosing a 65 Skylark I found. It is in great shape with 39k miles, 310 ci, 2 barrel Rochester carb, auto transmission with a console. Had been "sitting" for about three years with only quick starts and very short garage moves during those years. Started work on the car three days ago. The Skylark started hard but ran smoothly for at least 30 minutes after that. Got 10 gallons of new gas and added lead substitute. Then the heater core dumped all over the carpet. It was replaced yesterday. Started again and ran for 15 minutes. Everything is looking g
  5. Yes. I confirmed with an eBay search for 53 Buick hubcaps. 53 buick on eBay Thank you.
  6. Does anyone recognize these? What car were they on originally? Found four in trunk of used car.
  7. My name is Max and I really need some help diagnosing a 65 Skylark I found. It is in great shape with 39k miles, 310 ci, 2 barrel Rochester carb, auto transmission with a console. Had been "sitting" for about three years with only quick starts and very short garage moves during those years. Started work on the car three days ago. The Skylark started hard but ran smoothly for at least 30 minutes after that. Got 10 gallons of new gas and added lead substitute. Then the heater core dumped all over the carpet. It was replaced yesterday. Started again and ran for 15 minutes. Everything is looking g
×
×
  • Create New...