DeuceMan

Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0 Neutral

About DeuceMan

  • Rank
    Member
  • Birthday 11/16/1952

Profile Information

  • Gender:
    Male

Recent Profile Visitors

224 profile views
  1. I need the ductwork, heater box, evaporator box and the grille for my 74 Buick Century (Luxus)? Mine is in pretty bad shape. Thanks! ~
  2. Looking for a hood for a 1974 buick century 4-door Luxus. Mine is in really bad shape haha. Thanks for your time!
  3. Hi, I was wondering if anyone knows where I could find a washer pump for a 1967 Buick Skylark? I have looked and have not found one yet.. If anyone knows of a place or has one willing to sell, please let me know.
  4. Does anyone know how to get my automatic transmission indicator light to light up the indicator for Park / Neutral / Reverse / L2 on my dashboard for my 1967 Skylark? I don't understand how my light is supposed to go through the metal to show it, maybe it's just a bad design? Maybe there is some kind of special incandescent light that lights it up or is there something else I should do, not sure? Thanks if anyone knows.
  5. Does anyone know how to check the ignition wire voltage on both sides of the bulkhead connector in my 1967 Buick Skylark? The resistor wire is burning hot and it's not letting the alternator charge the battery like it should. I have a new alternator, but it won't charge the battery, it only gets 12.5 volts when its running but it should like 13.9 or 14.2. I believe that the problem is the ignition wire and after I do check it, how many volts should it be? Thanks.
  6. Thank you Rivived, I may have to look into that.
  7. Thanks ted sweet, but I already changed two alternators and got the same results.
  8. Thanks ol' yeller, but I replaced the battery, voltage regulator, and the alternator with all brand new, but the battery still drains. And the voltage regulator shows that it's not doing as it should, even with the new one.