Recian

Members
  • Content Count

    825
  • Joined

  • Last visited

Community Reputation

10 Good

About Recian

  • Rank
    Overworked and Underpayed
  • Birthday 07/12/1988
  1. ah so refreshing seeing pics reminds me of days driving the car and riding in it while my bro had it.
  2. naw i can have the intake off in about 30 mins. MAKE SURE if you do change them you get some blue loctite and clean the bolts and re-apply loc-tite when you tighten it back down. But a long crank time sounds like fuel pressure drop. Id think it's time to do the fuelp pump and pulsator. Trust me you'll need a new pulsator or 2" of FUEL INJECTION (not standard) hose to eliminate it. It will leak with a new pump because it's rubber seals will stick to the pump and when removed after 25 years it'll no longer be rubber but plastic and hence no seal. I've got the BOSCH fuel pump I put in the reatta but I was going to put it in my subaru since it has some rust in the tank. But before going through that extreme endeavor i'd take the 4 1/2"s off and remove the fuel rail with the gauge installed and car off and see if you have a leaking injector first.
  3. easy way to find out is go to harbor freight and pick up a $20 fuel pressure gauge. The generic adapter screws onto your fuel rail right up top. Install it and crank the car up til pressure stabalizes then turn it off. If fuel pressure drops you've got a leaking injector or pulsator. If pressure is consistant after shut off (which it will drop some but stabalize not continue dropping) then your fuel system isnt the problem. Make sure you arent losing coolant. Rough startup means something is getting in the combustion chamber when the car is off which leads to gas or coolant in the combustion chamber. Once it burns all that out it smooths out. I think you may have leaking intake gaskets. Pretty common as you know. And no you probably wont see white smoke as it'll be such a small amount it'll evaporate before it hits the end of the exhaust system. Just a heads up, that's what was wrong with mine when I bought it.
  4. Yea that plastic is hitting the block behind the sprocket youll need to split it apart
  5. Maybe someone jbwelded that one in there lol you could always get a cheap timing set and acdelco magnets are cheap
  6. a magnet could work but if the one in the sprocket is the opposite polarity it'll just push it further inside. An extention maybe? it'll stick to the metal
  7. Outlander is kind of a pain to change the belt but nothing compared to other mitsu's
  8. Fast idle could be a vacuum leak caused by disturbing the intake and related hoses. And no the sensor only effects the gauge. A plugged pcv could cause you to burn oil by overpressurizing and blowing by rings or seals. Did he replace the pcv while he had the intake off? Btw they do make new rubber grommets for the pcv. I did a review about it awhile back
  9. It wont hurt anything. Itll fall into the pan or stick to the block. Its magnetic so it wont go anywhere. Mine was stuck to the block when i took mine out.
  10. Sinister performance LLC has done it. Gmtuners.com. theyre who id talk to. Theres also an extensive 3 page post about it if you look about 10 posts down on the forums list. Like NC said the series1 is a bolt on swap and simply requires sinister to reprogram your prom chip for about $150
  11. Check tps is around .4 volts. Also check your throttle body. If its dirty youre not going to idle no matter how clean that iac valve is. Thats always the first place i look on any stall issue on any car that has no codes
  12. hey she's got new pioneer 5.25"s in the doors too just letting you know if you havent pulled the panels yet.
  13. water pump doesnt have to come off. Just need to take a couple 1/2"s out of it. Rough start when cold could really be many things. Maybe a leaking injector, blown head gasket or as simple as just needing a tune-up. From what i was told cam sensor doesnt have much drivability issues. Also oil sensor has no issue on burning oil. The valve seals and piston rings are the only things that effect that.
  14. I had it down to 2 mins on my car. I had the bracket removed since the dampener's nut snapped off so it wasnt there there was no reason to have a bracket
  15. This is the best forum out there for anything. That's kinda why i regret selling mine. Guess i'll just have to school you guys in subaru to stay up here