Jump to content

zagato

Members
  • Content Count

    33
  • Joined

  • Last visited

Posts posted by zagato

  1. I am having a problem with my heater/ac controls.  When selecting the control buttons it does not matter whether the vent, floor or defroster is selected.  The air mostly comes out of the defroster and a bit out of the heater regardless but not the vents.  I suspect it is a vacuum problem.  Can anyone suggest where to start?

  2. I bought another TC, this one a low mileage 16V out of Atlanta.  My last TC was a V6 and my experience with the 16 valve is nil.  I have the Chrysler dealer repair manual, for the TC, but it does not specify how to gain access to the distributor.  Can anyone share some information on this?  I also want to put new plugs in it and it appears that the valve cover gasket should be replaced as I noticed a small amount of engine oil at the bottom of each spark plug as they sit before being removed.  Which brings up another question; what size socket is needed for the spark plug?

  3. Hi Hemi, I obtained a Reatta pressure switch from a supplier suggested by TC parts.  The Reatta switch came with a matching plug that needs to be wired into the TC system.  The Reatta plug has splines instead of pins like the TC and the pattern is different.  I obtained a wiring diagram from the Reatta blog.  If you could send me the TC wiring diagram that would be great.

  4. Barney and Ronnie, thanks very much for the info.  I have a TC maintenance manual with the wiring schematic.  I really appreciate the input.  I will have the mechanic work on this.   I would like to keep the Teves system, but it is a challenge.

  5. Hi Guys.  I am not a Reatta owner, but I do own a TC and I am looking for help with the brake pressure switch connection.  Last fall I experienced a antilock brake failure on the Teves system.  Since then I replaced the accumulator and obtained a NOS brake pressure switch for the Teves II system.  TC Parts directed me to a supplier for Buick Reatta parts in order to get this switch.  Before the switch was replaced the brake pump would run and cycle, however the antilock brake light was still illuminated after replacement of the accumulator.  The Reatta parts suppler also sent along a plug that would compatible with the current TC Maserati connection, however the wiring designation for the TC plug is different from that for the Reatta plug.  We initially supposed the A,B,C,E wire designation for the Reatta plug corresponded directly to the 1,2,3,4 of the TC plug, i.e. 1 would match with A, 2 would match with B etc.  Well this obviously is not correct as now the pump will not run and cycle. How does the wiring designation correspond for utilizing the Reatta switch wiring to the TC plug?  Can anyone help with this?   

  6. Last fall I experienced a antilock brake failure on the Teves system.  Since then I replaced the accumulator and obtained a NOS brake pressure switch for the Teves II system.  TC Parts directed me to a supplier for Buick Reatta parts in order to get this switch.  Before the switch was replaced the brake pump would run and cycle, however the antilock brake light was still illuminated after replacement of the accumulator.  The Reatta parts suppler also sent along a plug that would compatible with the current TC Maserati connection, however the wiring designation for the TC plug is different from that for the Reatta plug.  We initially supposed the A,B,C,E wire designation for the Reatta plug corresponded directly to the 1,2,3,4 of the TC plug, i.e. 1 would match with A, 2 would match with B etc.  Well this obviously is not correct as now the pump will not run and cycle. How does the wiring designation correspond for utilizing the Reatta switch wiring to the TC plug?  Can anyone help with this?   The Reatta switch has splines and the TC switch has pins.  Please see photo.

    brake pressure switch connection.png

  7. Guys,

     

    I recently replaced the accumulator on my brake system and bled the brakes without issue thanks to input from Hemi.  There was a lot of air in the lines, especially from the rear brakes.  I no longer have a "hard pedal", but something is not right.  The brake pump now runs continually and does not shut off.  Could it be the pressure switch?  I would appreciate any suggestions.

  8. Thanks Hemi, the accumulator came off like a charm.  Once I replaced it the "hard pedal" problem went away but the red brake light is still lit and I notice there is a low humming sound after the brake pump shuts off within a few seconds.  The humming sound persists until I start the engine after which I wouldn't be able to detect the humming over the engine running.  The pedal is not "hard" but will occasionally have a momentary vibration feel and the brake reservoir appears to have a little more fluid in it than before the accumulator replacement.

     

    Bill

  9. Hi Guys,

     

    I need some help with my engine problem.  I have a 1990 TC with a 3 litre V6.  Last week when starting the car the engine immediately revved up to 4500 rpms and will not return to normal idle. The fault code read 14 which would indicate the MAP sensor voltage is too low.  However I checked the voltage and it read at 4.8 at the output.  I went ahead and changed the MAP sensor and any vacuum hose that showed any sign of cracking.  I also changed the throttle position sensor and I still have the high revving when starting the engine.  Does anyone have an idea of what the problem is?  I am open to any suggestion.

  10. Does anyone have a suggestion on how to remove a frozen brake rotor.  I tried the method using the bolts through the mounting bracket for the calipher, but the bolt with the nut that is supposed to apply pressure against the back of the rotor does not seat squarely on the rotor back.  The position of the mounting bracket and the configuration of the rotor only allows the outer edge of the nut pressing against the rotor back.

×
×
  • Create New...