Jump to content

Mike1904

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

10 Good

About Mike1904

  • Rank
    Junior Member
  • Birthday 09/14/1947
  1. This car has the oil drip lube system, but the flywheel seems to be throwing oil on the bottom of the seat - which is wood. Is this normal? And does anyone know if there was some sort of protection to keep the oil from soaking into the wood seat frame? Seems a little dangerous.
  2. Got it running again. Tinkered with the valve springs, then pushed it up and down the drive throwing it into gear. We finally broke something loose and started getting compression. Went back to the crank and got it started. Several trips around the block, started and stopped it several times and now it is running smooth. The brass lanterns are shined and working. the brass hubcaps, radiator, steering wheel spokes, dash bar, front decorations - well, all the brass is shined. The neighbors all waved as we drove by and the kids poured into the street to see it. That one cylinder sure is lo
  3. I have a 1904 Runabout - french hood. My father-inlaw rebuilt it in the 40s, it was his dad's. I know of a few others that that are apparently out there. It was running until he passed away, now I'm trying to get it going and I'm no mechanic. Almost had it running, but then gas started pouring out of the sediment bowl. Got that fixed. Has a hairline crack in the brass top of the radiator that dripped a little. Got it started, backed it up. Worked fine. BUT THEN, 3 days later tried to start it and NO COMPRESSION when trying to crank it. Checking for air leak, or stuck valve, or valve-sp
×
×
  • Create New...