Sign in to follow this  
allcars

1940-1941 Rear Turn Signal Back/Socket Needed

Recommended Posts

Looking for one of the two cover/socket pieces that mount on the inner side of the 1940-41 Buick decklid. These hold the turn signal bulbs in place and serve as a "reflector" more or less for the bulb (see photo).

Includes the socket for the bulb and the socket on one of mine is "toast."  

The Buick part number is 924830 and the application is for all 1940 and 1941 Buicks, right or left. Don't need NOS, just a housing with a nice bulb socket that has lead a dry life.

Everything else in my car's turn signal assembly seems fine.

PM me if you have one you'll part with.

 

Thanks!

 

IMG_9019.JPG.509b34cf686351a846518523d8623f69.JPG

 

Allcars

Share this post


Link to post
Share on other sites

Odd that the parts book would say that it was correct for 1941, because it wasn't used in '41. The trunk-mounted signals were introduced in '39 and used in '40, but in '41 they moved the signals into the taillight housings.

 

Anyway, this is kind of digression, but perhaps a '39 would also work? You won't have any results if you search for '41. I've seen complete assemblies show up on Ebay now and then, which might be your only way to get that part. I might also try Doug Seybold @ 440-835-1193 and see if he has one in his vast cache of parts and parts cars.

 

Hope this helps.

Share this post


Link to post
Share on other sites

Thanks for the suggestions, Matt. You are right, of course, on the '41 signals' location. Doh!

 

Checking the January 1941 Master Parts Book again, the application for the '40 part I need reads, "1940; 1941-42-49.  I realize now that it is telling me that the '40 style signals were carried over on only the Model 49 Estate Wagons for 1941 and 1942 (because of their taillight design)—I initially misread the listing as meaning all 1941, and just the Estate Wagon in 1942 only—but I should have remembered that the '41s are different, even so. The book does call out the '39 part as different for some reason.

 

IMG_9348.jpg.7de9a10e023f62a4e21bb11fea28d14c.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this