Tom Devoe

Rebuilding a Stromberg UR-2

Recommended Posts

Hi All - I'm knee deep in rebuilding a Stromberg UR-2 carb for my 31 Model 54.  I have two different carbs that I've disassembled and I'm cleaning up while waiting for a rebuild kit to be made for me.  I've noticed some of the parts are different in each carb.  One, I've been told was originally on a Studebaker, but not entirely sure.  The most noticeable difference are the holes drilled through the accelerator pump metering jet.  One has two holes, one has just one hole.  Any way to tell which one to use, or will this be a trial and error thing when the car is running?  Also, is the Accelerator pump able to be disassembled?  One is able to be depressed fully compressing the spring, and one just moves a little bit.  I'll attach a few pics.  Were there different idle tubes, main jet nozzles, economizer valves, air bleeder nozzles etc. for different applications of this carb?  Anyone know how long Stromberg made this carburetor and what manufacturers used them?  I plan on using a Caswell black oxide plating kit to finish the cast iron body.  Is this compatible with modern fuel if I dip the whole thing, or should I just paint the outside (leaving the inside bare steel) after reassembly.  Thanks for the help!

20171211_070425.jpg

20171211_070444.jpg

Share this post


Link to post
Share on other sites

Only a guess but since they are just an accelerator pump I doubt it will matter which you use because they only shoot in gas when you press the throttle quickly. 

 

Share this post


Link to post
Share on other sites

I didn't notice before, but looking at these close up pictures of these accelerator pump parts, and now looking at them confirms that the one that cannot be depressed more than an 1/8" has a sleeve under the spring to prevent it from being depressed.  Might be a later design, but it makes a lot of sense.  If the spring depresses while the accelerator pump is depressed, the fuel will just be displaced, and won't be forced through the little hole and eventually into the venturi (if I'm correct in my assessment on how this thing works).

 

No advise on using the Caswell black oxide kit?  I guess I'll try it and post my results for others!

 

I plan on sand blasting these iron carb bodies.  Is that a good idea, or do I run the risk of clogging small passages up with sand?

 

 

 

Edited by Tom Devoe (see edit history)

Share this post


Link to post
Share on other sites

The Caswell black oxide will work perfectly, I used black oxide from Frost, same stuff as the Caswell kit, on one that I restored for my fathers 32 Rockne and it turned out great and it still looks great after three years. I dipped the whole bodies as that is how they did it originally. All the unrestored UR-2's that I have seen have just been black oxide finish, none have been painted. So I assume that is how they should be. Thought as you can see from the first pic that I have posted it looks like it has some paint on the lower body. So the choice is yours. 

 

Also you can see that there is a faint identification tamping on the top body near the fuel inlet elbow. Both are carbs pictured are stamped R-30 which means that they are for a 32 Rockne. What that the 4 and 2 stand for I have not figured out yet.

 

5a36472fe7599_StrombergUR-2frgasare-orginal-1.thumb.jpg.b78ef2486bde7bbff87b4dac9e8a95a0.jpg

 

5a364735db753_StrombergUR-2-1.thumb.JPG.d8d031eee404ae4f929f5e070254e30e.JPG

 

I would not worry about sandblasting the bodies, if you use fine grit sand and blow all the passages out real thoroughly after blasting you should have no problem with clogging.

 

I have also posted some general information and a parts list ,that I found on the net, for the UR-2 that might be of some help to you.

Stromberg UR-2 and UUR-2 - Information.pdf

Stromberg URO-1 UR-2 and UR-23 - Partscatalog.pdf

Edited by M29C3284 (see edit history)

Share this post


Link to post
Share on other sites

M29 - Thanks for the info! I did download those pages a while ago from one of your previous posts, and they are awesome. I didn't know about the stamping on the carb body. I looked at mine, and one does have the R-30 stamp. It's very light, but there. The acc pump with the sleeve, and the 2 hole metering jet came from that carb, so they will be used on the rebuild for my Stude. I appreciate you sharing that info, now I know I have the right parts!

Share this post


Link to post
Share on other sites

Got the carbs finished up today. Instead of buying the Caswell black oxide kit, I made my own juice. I followed directions I saw on You Tube, and I think they turned out well. It was easy, but time consuming. I'll be using the carb on the right, as I've put the throttle pivot arm on the same side as the original U-2. 

Question for those using a UR-2. I've noticed that the accelerator pump cam that pushes the pivot arm down allows the carb to lock in the full throttle position. I guess a strong return spring on the actuating rod will not allow this to happen, but it seems like a dangerous design. Did you alter the design or are you using it as is? 

image.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

Really nice work on those carbs.

 

I can only speak for the Rockne installation. It uses a setup where the return spring tension is adjustable. It quite strong even if it's not tensioned. And also the linkage it setup so that the throttle can't go past fully open and lock up.

Share this post


Link to post
Share on other sites

Thank you M29C3284!  Any way you could post a picture of the accelerator linkage on the Rockne?  It might be quite different from mine, and maybe I can adjust/alter mine to act the same.

Share this post


Link to post
Share on other sites

Thank you M29! A picture is worth a thousand words, eh? My set up is very similar, but my spring isn't as big, and I don't have the rear mount for it. I will fab something up and post how it works.

Share this post


Link to post
Share on other sites

Thank you. I have a similar set-up on another make car, but my forward spring mounting tang is on a smooth rod, not threaded as yours is. It doesn't move.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now