Jump to content


Photo
- - - - -

1967 conti convert.. a/c questions


  • Please log in to reply
3 replies to this topic

#1 samster1

samster1

    Junior Member

  • Members
  • PipPip
  • 22 posts

Posted 09 September 2012 - 11:55 PM

Hey guys..well got my 67 back after 4 months of complete engine rebuild...however still no a/c..we filled it up with max amount of freon and it blew cold for bout 20 min then started warming up (never got colder than 70 ) after 30 min it was blowing hot air..massive leak..also evaporator ices up ..Im considering saying to hell with it and getting vintage air in dash (obviously some modifications are needed)...my mechanic is not a true a/c guy..should I give it one more shot with an expert..could it be as simple as a hose leaking?

Thanks in advance

#2 gdcont

gdcont

    Senior Member

  • Members
  • PipPipPip
  • 110 posts

Posted 10 September 2012 - 02:43 AM

The fact that the evaporator freezes up means that you have a blockage in the system possibly at the evap. Also if you had a leak, the center of the compressor would stop turning to protect the compressor because the freon has oil mixed with it for lubrication. Yes I would bring it to an A/C specialist that is experianced with an older system. He should be able to diag the problem with gauges installed. Good luck George.

#3 samster1

samster1

    Junior Member

  • Members
  • PipPip
  • 22 posts

Posted 11 September 2012 - 12:26 AM

Thanks so much I took your advice found a well reviewed A/c guy down here in Miami and his suggestion was to vintage air the car...well there goes my hershey pa future (ha ha) Im a driver not a show guy anyhow so who gives a damn..Id rather be ice cold in the car than original...Thanks again

#4 peecher

peecher

    Senior Member

  • Members
  • PipPipPipPip
  • 1,508 posts

Posted 11 September 2012 - 03:44 PM

You might contact Lincoln Land in Clearwater(FL) 727-446-2193. They specialize in providing service for these "modern" Lincolns. They may be able to help restore your original system?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users