Smokeywolf

Members
  • Content count

    11
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Smokeywolf

  • Rank
    Member
  1. This will be my last post on this problem. Why! Because it's now going the way Pontiac intended Cruisers along at a comfortable 85mph I think, it will go a bit faster but simply not got the guts. The last thing to be replaced were the HT leads. They were not replaced earlier because the last owner just had a brand new set fitted. But as a last resort a new set was fitted. Which solved the problem. Which just goes to show not to take things for granted, including the obvious I would like to thank everyone who has taken the time to offer advice.
  2. Hi Faso thanks for your reply The fuel filter was checked then removed and refitted after I had proven it was not causing any problems. The distributor advance and retard has also been checked and works. But it's not an indication that the advance curve is correct.
  3. Here is an update on the work completed to date. Compression 110 psi average across all cyliners. Heat raiser checked and working correctly Exhaust removed to check if the exhust system was blocked.. all ok. Carb rebuilt no improvement. Non of the work done has improved the engine Does anyone have a good distributor they would like to sell?
  4. Not sure we're my reply has gone so I will rewrite. The Pertronix is 6volts and also fitted a new coil as well the results are good and ignition seems to have improved. Timing has been set from 19 deg to 3 deg it now starts on the button everytime. Using Bloo's information the heat raiser is fitted incorrectly I will refit as per Bloo's instructions. Grimy, great advice I will follow up and check than you. It does appear that the engine is not set to workshop specifications. This means I will need to start from the basics and check everything first up will be rechecking compression and testing leakdown. Then moving forward once I am happy with the results. Lastly thank you to everyone that has given advice it's much appreciated. Keep it coming and I will update the results as I go.
  5. That's great stuff Bloo. Very well explained thankyou
  6. That's great stuff Bloo. Very well explained thankyou
  7. Spoken to the original owner. Yes the car had these problems before. I'm checking out the power valve . Also the distributor bob weights. But I could do with some information regarding the operation of the valve in the manifold. Does the spring on the outside of the manofold expand moving the valve to direct the exhuast gas flow down the exhuast system. Or is it a damper if so how does it work?
  8. Checked compressions today on average came out at 70psi This can't be correct as you need 90 psi to compress the fuel enough to push the piston down then the spark ignites Oil pressure is 40 psi so piston rings and big ends must be ok Exhaust is breathing ok Heat raiser is working moving freely and held open when engine was reved up. expansion spring is not moving Sticking values possible but on all is questionable. Cam Timing not sure any ideas?
  9. I'm new to the world of flat heads as I have just purchased a 54 Starchief with L8 engine. My problem is this. The Engine holds back and does not freely rev. Getting to 45 mph is slow but reasonable but will not accelerate much more than that. So what could it be? First thing I noticed was the exhuast had a small blow. Causing the air fuel mixture to be incorrect. New gasket fitted.= No improvement in performance. Next was possibly weakened spark at higher RPM . Petronoix igniter and coil fitted = very small improvement. Ignition timing checked, looked miles out so readjusted the timing to between 3 and 5 deg before TDC.taken from the Harmonic blancer. A road test found this made things wrose. I'm now running 19 deg BTC and can get 50 at a push. Still not working correctly. Other Observations : While running the engine I noticed the throttle connecting rods becoming very hot to the touch!! Spark plugs all have a small spark but all working Advance and retard appears to all so be working. Any ideas will be greatly received.
  10. I'm new to the world of flat heads as I have just purchased a 54 Starchief with L8 engine. My problem is this. The Engine holds back and does not freely rev. Getting to 45 mph is slow but reasonable but will not accelerate much more than that. So what could it be? First thing I noticed was the exhuast had a small blow. Causing the air fuel mixture to be incorrect. New gasket fitted.= No improvement in performance. Next was possibly weakened spark at higher RPM . Petronoix igniter and coil fitted = very small improvement. Ignition timing checked looked miles out so readjusted the timing to between 3 and 5 deg before TDC.taken from the Harmonic blancer. A road test found this made thing wrose. I'm not running 19 deg BTC and can get 50 at a push. Still not working correctly. Other Observations : While running the engine I noticed the throttle connecting rods becoming very hot to the touch!! Spark plugs all have a small spark but all working Advance and retard appears to all so be working. Any ideas will be greatly received.